summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2020-12-19 01:04:41 +0100
committerJens Georg <mail@jensge.org>2020-12-19 17:47:54 +0100
commit774475787e7cf59b8d10a104f12904560bf31b88 (patch)
tree0d4f286113f0e9a38262199c9a9ddfc2fe0cd5f5 /meson.build
parentcc7da54ef7849d494209e2337c9150950604dae7 (diff)
downloadrygel-774475787e7cf59b8d10a104f12904560bf31b88.tar.gz
wip: Fix gtkdoc generation and installationwip/phako/190
Fixes #190
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4aa683d6..48301dce 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-project('rygel', 'vala', 'c', version : '0.40.0', meson_version : '>= 0.50.0')
+project('rygel', 'vala', 'c', version : '0.40.0', meson_version : '>= 0.55.0')
vala = meson.get_compiler('vala')
# Check for the required vala version
@@ -9,6 +9,8 @@ if not vala_version_found.version_compare(vala_version_required)
error('Found Vala version @0@, need @1@'.format(vala_version_found, vala_version_required))
endif
+install_doc = find_program('build-aux/meson/install-gtkdoc.py')
+
i18n = import('i18n')
gnome = import('gnome')
@@ -60,6 +62,7 @@ conf.set_quoted('LOCALEDIR', join_paths(get_option('prefix'), get_option('locale
conf.set_quoted('MX_EXTRACT_PATH', join_paths(rygel_libexecdir, 'mx-extract'))
conf.set_quoted('DESKTOP_DIR', join_paths(get_option('prefix'), get_option('datadir'), 'applications'))
conf.set_quoted('VERSION', meson.project_version())
+conf.set('EXAMPLEDIR', join_paths(meson.current_source_dir(), 'examples'))
config_include = include_directories('.')
add_global_arguments(['-include','config.h'], language : 'c')