summaryrefslogtreecommitdiff
path: root/SConstruct
diff options
context:
space:
mode:
authorGary Oberbrunner <garyo@oberbrunner.com>2012-08-12 23:25:31 -0400
committerGary Oberbrunner <garyo@oberbrunner.com>2012-08-12 23:25:31 -0400
commitc6b838a9c8dd8b911637cacbace03419f89001fa (patch)
treed623ba107f87296c3b7101d5d798e767125ba2f4 /SConstruct
parentfca1fdbf19a60e04eb1909d7b6af5130b3319c9f (diff)
downloadscons-c6b838a9c8dd8b911637cacbace03419f89001fa.tar.gz
Fix Debian build process.
Each release needs to update debian/changelog, and it needs to be in a particular format since the deb build process reads and parses it to get the version number in the .deb. Also fixed a few other deb-build-related errors.
Diffstat (limited to 'SConstruct')
-rw-r--r--SConstruct2
1 files changed, 1 insertions, 1 deletions
diff --git a/SConstruct b/SConstruct
index fd513963..46a7dafd 100644
--- a/SConstruct
+++ b/SConstruct
@@ -1026,7 +1026,7 @@ for p in [ scons ]:
if dh_builddeb and fakeroot:
# Our Debian packaging builds directly into build/dist,
# so we don't need to Install() the .debs.
- deb = os.path.join(build_dir, 'dist', "%s_%s-1_all.deb" % (pkg, version))
+ deb = os.path.join(build_dir, 'dist', "%s_%s_all.deb" % (pkg, version))
for d in p['debian_deps']:
b = env.SCons_revision(os.path.join(build, d), d)
env.Depends(deb, b)