summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/control4
-rw-r--r--debian/dirs1
-rw-r--r--debian/postinst6
-rw-r--r--debian/rules10
5 files changed, 14 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index 84f2b2e5..063cba41 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,8 @@
-scons (0.96-94) unstable; urgency=low
+scons (0.96-96) unstable; urgency=low
* Pre-release of eighth beta release.
- -- Steven Knight <knight@baldmt.com> Sun, 07 Jan 2007 18:36:20 -0600
+ -- Steven Knight <knight@baldmt.com> Thu, 12 Apr 2007 12:36:25 -0500
scons (0.96-1) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 7e0d2a5f..ab360e6c 100644
--- a/debian/control
+++ b/debian/control
@@ -2,12 +2,12 @@ Source: scons
Section: devel
Priority: optional
Maintainer: Moshe Zadka <moshez@debian.org>
-Build-Depends-Indep: debhelper (>> 2.0.0), python2.2-dev
+Build-Depends-Indep: debhelper (>> 2.0.0), python-dev (>> 2.2)
Standards-Version: 3.5.6
Package: scons
Architecture: all
-Depends: python2.2
+Depends: python (>> 2.2)
Description: A replacement for Make
SCons is an Open Source software construction tool--that is, a build
tool; an improved substitute for the classic Make utility; a better
diff --git a/debian/dirs b/debian/dirs
index 47f84cfc..93a451b6 100644
--- a/debian/dirs
+++ b/debian/dirs
@@ -1,4 +1,3 @@
usr/bin
-usr/lib/python2.2/site-packages
usr/share/doc/scons
usr/share/man/man1
diff --git a/debian/postinst b/debian/postinst
index 6923e0f5..ed8ed5c1 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -7,11 +7,13 @@ if [ "$1" = "configure" ]; then
fi
NAME=scons
+PYTHON_VERSION=`python -V 2>&1| cut -d" " -f2 | cut -d"." -f0-2`
+PYTHON_EXE_NAME=`which python$PYTHON_VERSION`
case "$1" in
configure|abort-upgrade|abort-remove|abort-deconfigure)
dpkg --listfiles $NAME | grep '\.py$' | \
- xargs -n 1 /usr/bin/python2.2 -c 'import py_compile,sys;py_compile.compile(sys.argv[1])'
+ xargs -n 1 $PYTHON_EXE_NAME -c 'import py_compile,sys;py_compile.compile(sys.argv[1])'
dpkg --listfiles $NAME | grep '\.py$' | \
- xargs -n 1 /usr/bin/python2.2 -O -c 'import py_compile,sys;py_compile.compile(sys.argv[1])'
+ xargs -n 1 $PYTHON_EXE_NAME -O -c 'import py_compile,sys;py_compile.compile(sys.argv[1])'
;;
esac
diff --git a/debian/rules b/debian/rules
index 4250539d..1eaf4de5 100644
--- a/debian/rules
+++ b/debian/rules
@@ -6,7 +6,9 @@
# Overridable variables added to support building test .deb files
# as part of routine SCons builds. --SK
BUILDDEB_OPTIONS=
-PYTHON=/usr/bin/python2.2
+PYTHON_VERSION=`python -V 2>&1| cut -d" " -f2 | cut -d"." -f0-2`
+PYTHON_PATH=/usr/bin/python
+PYTHON=$(PYTHON_PATH)$(PYTHON_VERSION)
#######
# Uncomment this to turn on verbose mode.
@@ -51,9 +53,9 @@ install: build
@# already exist on our non-Debian test build systems. Hence,
@# we do a lot of mkdir -p and rm -f here... --SK
@########
- mkdir -p debian/scons/usr/lib/python2.2/site-packages/
- rm -rf debian/scons/usr/lib/python2.2/site-packages/SCons
- cp -r build/lib/SCons debian/scons/usr/lib/python2.2/site-packages/
+ mkdir -p debian/scons/usr/lib/python$(PYTHON_VERSION)/site-packages/
+ rm -rf debian/scons/usr/lib/python$(PYTHON_VERSION)/site-packages/SCons
+ cp -r build/lib/SCons debian/scons/usr/lib/python$(PYTHON_VERSION)/site-packages/
mkdir -p debian/scons/usr/bin/
rm -f debian/scons/usr/bin/scons