summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorSadrul Habib Chowdhury <sadrul@users.sourceforge.net>2009-02-06 10:29:05 -0500
committerSadrul Habib Chowdhury <sadrul@users.sourceforge.net>2009-02-06 10:29:05 -0500
commitf823083eee6bb3bf4c52cc2b32b1617bf291b1c0 (patch)
tree01a8a8924c2c03d10d9ffb52a4b1f6a912935e29 /src/configure.in
parent940c63996183bd7d609d2bce50123d5a9f92686c (diff)
parent98b6b4105b60150c5bf9d022b2e7de698a62a797 (diff)
downloadscreen-f823083eee6bb3bf4c52cc2b32b1617bf291b1c0.tar.gz
Merge branch 'master' into cmd-alias
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in13
1 files changed, 2 insertions, 11 deletions
diff --git a/src/configure.in b/src/configure.in
index 9cd5d3a..9db3dd6 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -45,6 +45,7 @@ AC_PROG_CC
AC_PROG_CPP
AC_PROG_GCC_TRADITIONAL
AC_ISC_POSIX
+AC_USE_SYSTEM_EXTENSIONS
AC_TRY_RUN(main(){exit(0);},,[
if test $CC != cc ; then
@@ -1201,17 +1202,7 @@ main() {
exit(0); /* libc version works properly. */
}], AC_DEFINE(USEMEMCPY))
-AC_MSG_CHECKING(long file names)
-(echo 1 > /tmp/conftest9012345) 2>/dev/null
-(echo 2 > /tmp/conftest9012346) 2>/dev/null
-val=`cat /tmp/conftest9012345 2>/dev/null`
-if test -f /tmp/conftest9012345 && test "$val" = 1; then
-AC_MSG_RESULT(yes)
-else
-AC_MSG_RESULT(no)
-AC_DEFINE(NAME_MAX, 14)
-fi
-rm -f /tmp/conftest*
+AC_SYS_LONG_FILE_NAMES
AC_MSG_CHECKING(for vsprintf)
AC_TRY_LINK(,[vsprintf(0,0,0);], AC_MSG_RESULT(yes);AC_DEFINE(USEVARARGS), AC_MSG_RESULT(no))