summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorSadrul Habib Chowdhury <sadrul@users.sourceforge.net>2012-01-19 16:35:03 -0500
committerSadrul Habib Chowdhury <sadrul@users.sourceforge.net>2012-01-19 16:35:03 -0500
commitc795ac322ff7c81c8d57445337c9f70cba226d1f (patch)
tree00362a9b3c203b64de2400f0a124f9dc9e2a5397 /src/configure.in
parent869278e490913531a98602b8bec5cc08831aa46d (diff)
parent8cf5efc07048abee125a24652768f4b24fc761bf (diff)
downloadscreen-unicode++.tar.gz
Merge remote-tracking branch 'origin/master' into unicode++unicode++
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/configure.in b/src/configure.in
index bd29de2..4184947 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1217,14 +1217,14 @@ AC_HEADER_DIRENT
AC_MSG_CHECKING(for setenv)
if test -z "$ac_setenv_args"; then
- AC_TRY_COMPILE(
+ AC_TRY_LINK(
[#include <stdlib.h>],
[
setenv((char *) 0, (char *) 0, 0);
], ac_setenv_args=3)
fi
if test -z "$ac_setenv_args"; then
- AC_TRY_COMPILE(
+ AC_TRY_LINK(
[#include <stdlib.h>],
[
setenv((char *) 0, (char *) 0);
@@ -1294,6 +1294,11 @@ test -n "$seqptx" && LIBS="-ltermcap -lc -lsocket -linet -lnsl -lsec -lseq"
AC_TRY_RUN(main(){exit(0);},,AC_MSG_ERROR(Can't run the compiler - internal error. Sorry.))
+ETCSCREENRC=
+AC_MSG_CHECKING(for the global screenrc file)
+AC_ARG_WITH(sys-screenrc, [ --with-sys-screenrc=path to the global screenrc file], [ ETCSCREENRC="${withval}" ])
+AC_SUBST(ETCSCREENRC)
+
AC_OUTPUT(Makefile doc/Makefile, [[
# a hook for preserving undef directive in config.h
mv config.h conftest