summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4e20eefd2..b66a81486 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -875,18 +875,6 @@ if(LIBC)
else()
set(HAVE_ALLOCA_H 1)
set(HAVE_ALLOCA 1)
- if(IOS OR TVOS) # assuming iOS / TVOS >= 10.0
- set(HAVE_CLOCK_GETTIME_NSEC_NP 1)
- else()
- CHECK_C_SOURCE_COMPILES("
- #include <AvailabilityMacros.h>
- #include <time.h>
- #if MAC_OS_X_VERSION_MIN_REQUIRED < 101200
- #error Need 10.12 or newer target
- #endif
- int main(int argc, char **argv) { return !clock_gettime_nsec_np(CLOCK_MONOTONIC); }
- " HAVE_CLOCK_GETTIME_NSEC_NP)
- endif()
endif()
check_struct_has_member("struct sigaction" "sa_sigaction" "signal.h" HAVE_SA_SIGACTION)