summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornekral-guest <nekral-guest@5a98b0ae-9ef6-0310-add3-de5d479b70d7>2011-11-19 15:13:17 +0000
committernekral-guest <nekral-guest@5a98b0ae-9ef6-0310-add3-de5d479b70d7>2011-11-19 15:13:17 +0000
commit21b505094ab88b61a5a2958931ce69db98bb72e4 (patch)
tree15ec490c5bc2d6f6c30ed8d9520bf6a7c3f88c4c
parent89c37173e115c6049dfda33df5cc038f23bca028 (diff)
downloadshadow-21b505094ab88b61a5a2958931ce69db98bb72e4.tar.gz
Refreshed patches.
-rw-r--r--debian/changelog15
-rwxr-xr-xdebian/patches/401_cppw_src.dpatch2
-rw-r--r--debian/patches/402_cppw_selinux8
-rw-r--r--debian/patches/428_grpck_add_prune_option31
-rw-r--r--debian/patches/429_login_FAILLOG_ENAB4
-rw-r--r--debian/patches/463_login_delay_obeys_to_PAM2
-rw-r--r--debian/patches/523_su_arguments_are_concatenated2
-rw-r--r--debian/patches/523_su_arguments_are_no_more_concatenated_by_default4
-rw-r--r--debian/patches/542_useradd-O_option4
-rw-r--r--debian/patches/900_testsuite_groupmems4
10 files changed, 27 insertions, 49 deletions
diff --git a/debian/changelog b/debian/changelog
index 5317dc6d..1e0b69aa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -33,17 +33,20 @@ shadow (1:4.1.5-1) unstable; urgency=low
- groupmod: document that /etc/passwd can be modified by groupmod -g.
Closes: #647308
- Updated patches
- + debian/patches/523_su_arguments_are_no_more_concatenated_by_default
- + debian/patches/505_useradd_recommend_adduser
- + debian/patches/463_login_delay_obeys_to_PAM
+ debian/patches/008_login_log_failure_in_FTMP
- + debian/patches/501_commonio_group_shadow
+ + debian/patches/401_cppw_src.dpatch
+ + debian/patches/402_cppw_selinux
+ + debian/patches/428_grpck_add_prune_option
+ debian/patches/429_login_FAILLOG_ENAB
- + debian/patches/508_nologin_in_usr_sbin
+ + debian/patches/463_login_delay_obeys_to_PAM
+ + debian/patches/501_commonio_group_shadow
+ + debian/patches/505_useradd_recommend_adduser
+ debian/patches/506_relaxed_usernames
+ + debian/patches/508_nologin_in_usr_sbin
+ debian/patches/523_su_arguments_are_concatenated
+ + debian/patches/523_su_arguments_are_no_more_concatenated_by_default
+ debian/patches/542_useradd-O_option
- + debian/patches/428_grpck_add_prune_option
+ + debian/patches/900_testsuite_groupmems
- debian/patches/008_su_get_PAM_username: Removed, feature supported
upstream.
- debian/patches/300_CVE-2011-0721: Removed, applied upstream.
diff --git a/debian/patches/401_cppw_src.dpatch b/debian/patches/401_cppw_src.dpatch
index 019f1cc1..501545c1 100755
--- a/debian/patches/401_cppw_src.dpatch
+++ b/debian/patches/401_cppw_src.dpatch
@@ -266,7 +266,7 @@
groupdel_LDADD = $(LDADD) $(LIBPAM_SUID) $(LIBAUDIT) $(LIBSELINUX)
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
-@@ -82,6 +82,7 @@
+@@ -83,6 +83,7 @@
src/chgpasswd.c
src/chpasswd.c
src/chsh.c
diff --git a/debian/patches/402_cppw_selinux b/debian/patches/402_cppw_selinux
index ebd90745..b92767fe 100644
--- a/debian/patches/402_cppw_selinux
+++ b/debian/patches/402_cppw_selinux
@@ -21,7 +21,7 @@ Depends on 401_cppw_src.dpatch
#include "exitcodes.h"
#include "prototypes.h"
#include "pwio.h"
-@@ -134,6 +137,22 @@
+@@ -139,6 +142,22 @@
if (access (file, F_OK) != 0) {
cppwexit (file, 1, 1);
}
@@ -42,10 +42,10 @@ Depends on 401_cppw_src.dpatch
+ }
+#endif /* WITH_SELINUX */
if (file_lock () == 0) {
- cppwexit ("Couldn't lock file", 0, 5);
+ cppwexit (_("Couldn't lock file"), 0, 5);
}
-@@ -162,6 +181,15 @@
- cppwexit (0,0,1);
+@@ -167,6 +186,15 @@
+ cppwexit (NULL,0,1);
}
+#ifdef WITH_SELINUX
diff --git a/debian/patches/428_grpck_add_prune_option b/debian/patches/428_grpck_add_prune_option
index ceb00b63..e71f1425 100644
--- a/debian/patches/428_grpck_add_prune_option
+++ b/debian/patches/428_grpck_add_prune_option
@@ -7,7 +7,7 @@ Status wrt upstream: It could certainly be submitted to upstream.
--- a/src/grpck.c
+++ b/src/grpck.c
-@@ -79,6 +79,7 @@
+@@ -81,6 +81,7 @@
/* Options */
static bool read_only = false;
static bool sort_mode = false;
@@ -15,37 +15,12 @@ Status wrt upstream: It could certainly be submitted to upstream.
/* local function prototypes */
static void fail_exit (int status);
-@@ -178,7 +179,7 @@
+@@ -203,7 +204,7 @@
/*
* Parse the command line arguments
*/
- while ((c = getopt_long (argc, argv, "hqrR:s",
+ while ((c = getopt_long (argc, argv, "hqprR:s",
- long_options, NULL)) != -1) {
+ long_options, NULL)) != -1) {
switch (c) {
case 'h':
- usage (E_SUCCESS);
-@@ -189,6 +190,9 @@
- case 's':
- sort_mode = true;
- break;
-+ case 'p':
-+ prune = true;
-+ break;
- default:
- usage ();
- }
-@@ -474,7 +478,12 @@
- /*
- * prompt the user to delete the entry or not
- */
-- if (!yes_or_no (read_only)) {
-+ if (!prune) {
-+ if (!yes_or_no (read_only)) {
-+ continue;
-+ }
-+ } else {
-+ puts (_("Yes"));
- continue;
- }
-
diff --git a/debian/patches/429_login_FAILLOG_ENAB b/debian/patches/429_login_FAILLOG_ENAB
index 214627a3..57a6d150 100644
--- a/debian/patches/429_login_FAILLOG_ENAB
+++ b/debian/patches/429_login_FAILLOG_ENAB
@@ -56,7 +56,7 @@ Note: It could be removed if pam_tally could report the number of failures
if (getdef_str("FTMP_FILE") != NULL) {
#ifdef USE_UTMPX
struct utmpx *failent =
-@@ -1288,6 +1303,7 @@
+@@ -1291,6 +1306,7 @@
*/
#ifndef USE_PAM
motd (); /* print the message of the day */
@@ -64,7 +64,7 @@ Note: It could be removed if pam_tally could report the number of failures
if ( getdef_bool ("FAILLOG_ENAB")
&& (0 != faillog.fail_cnt)) {
failprint (&faillog);
-@@ -1300,6 +1316,7 @@
+@@ -1303,6 +1319,7 @@
username, (int) faillog.fail_cnt));
}
}
diff --git a/debian/patches/463_login_delay_obeys_to_PAM b/debian/patches/463_login_delay_obeys_to_PAM
index 081d63df..26285ea1 100644
--- a/debian/patches/463_login_delay_obeys_to_PAM
+++ b/debian/patches/463_login_delay_obeys_to_PAM
@@ -67,7 +67,7 @@ Note: If removed, FAIL_DELAY must be re-added to /etc/login.defs
retcode = pam_authenticate (pamh, 0);
-@@ -1104,14 +1092,17 @@
+@@ -1107,14 +1095,17 @@
free (username);
username = NULL;
diff --git a/debian/patches/523_su_arguments_are_concatenated b/debian/patches/523_su_arguments_are_concatenated
index 97704877..0abc4c5f 100644
--- a/debian/patches/523_su_arguments_are_concatenated
+++ b/debian/patches/523_su_arguments_are_concatenated
@@ -10,7 +10,7 @@ Note: the fix of the man page is still missing.
--- a/src/su.c
+++ b/src/su.c
-@@ -1151,6 +1151,35 @@
+@@ -1150,6 +1150,35 @@
argv[0] = "-c";
argv[1] = command;
}
diff --git a/debian/patches/523_su_arguments_are_no_more_concatenated_by_default b/debian/patches/523_su_arguments_are_no_more_concatenated_by_default
index ebcdc92b..d4213451 100644
--- a/debian/patches/523_su_arguments_are_no_more_concatenated_by_default
+++ b/debian/patches/523_su_arguments_are_no_more_concatenated_by_default
@@ -30,7 +30,7 @@ Status wrt upstream: This patch is Debian specific.
#ifdef USE_PAM
static pam_handle_t *pamh = NULL;
static int caught = 0;
-@@ -951,6 +964,8 @@
+@@ -950,6 +963,8 @@
int ret;
#endif /* USE_PAM */
@@ -39,7 +39,7 @@ Status wrt upstream: This patch is Debian specific.
(void) setlocale (LC_ALL, "");
(void) bindtextdomain (PACKAGE, LOCALEDIR);
(void) textdomain (PACKAGE);
-@@ -1155,7 +1170,7 @@
+@@ -1154,7 +1169,7 @@
* resulting string is always given to the shell with its
* -c option.
*/
diff --git a/debian/patches/542_useradd-O_option b/debian/patches/542_useradd-O_option
index 8e506457..e607f245 100644
--- a/debian/patches/542_useradd-O_option
+++ b/debian/patches/542_useradd-O_option
@@ -21,7 +21,7 @@ Status wrt upstream: not included as this is just specific
<varlistentry>
--- a/src/useradd.c
+++ b/src/useradd.c
-@@ -1007,9 +1007,9 @@
+@@ -1009,9 +1009,9 @@
};
while ((c = getopt_long (argc, argv,
#ifdef WITH_SELINUX
@@ -33,7 +33,7 @@ Status wrt upstream: not included as this is just specific
#endif
long_options, NULL)) != -1) {
switch (c) {
-@@ -1132,6 +1132,7 @@
+@@ -1134,6 +1134,7 @@
kflg = true;
break;
case 'K':
diff --git a/debian/patches/900_testsuite_groupmems b/debian/patches/900_testsuite_groupmems
index 44879584..6bdc4978 100644
--- a/debian/patches/900_testsuite_groupmems
+++ b/debian/patches/900_testsuite_groupmems
@@ -53,7 +53,7 @@
--- a/debian/rules
+++ b/debian/rules
-@@ -61,6 +61,7 @@
+@@ -60,6 +60,7 @@
dh_installpam -p passwd --name=chsh
dh_installpam -p passwd --name=chpasswd
dh_installpam -p passwd --name=newusers
@@ -61,7 +61,7 @@
ifeq ($(DEB_HOST_ARCH_OS),hurd)
# login is not built on The Hurd, but some utilities of passwd depends on
# /etc/login.defs.
-@@ -91,3 +92,6 @@
+@@ -87,3 +88,6 @@
chgrp shadow debian/passwd/usr/bin/expiry
chmod g+s debian/passwd/usr/bin/chage
chmod g+s debian/passwd/usr/bin/expiry