summaryrefslogtreecommitdiff
path: root/bin/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>2000-11-21 18:16:48 +0000
committerMartin Baulig <martin@src.gnome.org>2000-11-21 18:16:48 +0000
commit4bef9ecf9296f5ba660ec873dd90af42ca1190bd (patch)
tree9066df1f4347c49f4beebe5721f805d2cb5df006 /bin/Makefile.am
parent1f8d693b87ce9132f3880809f52ede46727ef5e4 (diff)
downloadshared-mime-info-4bef9ecf9296f5ba660ec873dd90af42ca1190bd.tar.gz
New file. Autogen gnome-autogen.sh from it; added GNOME_COMMON_DATA_DIR
2000-11-21 Martin Baulig <martin@home-of-linux.org> * gnome-autogen.sh.in: New file. Autogen gnome-autogen.sh from it; added GNOME_COMMON_DATA_DIR and make it actually work. svn path=/trunk/; revision=1467
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
index 0edaa742..36bff37e 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -1,5 +1,15 @@
bin_SCRIPTS = gnome-autogen.sh
-EXTRA_DIST = gnome-autogen.sh
+## We create gnome-autogen.sh here and not from configure because we want
+## to get the paths expanded correctly. Macros like srcdir are given
+## the value NONE in configure if the user doesn't specify them (this
+## is an autoconf feature, not a bug).
+gnome-autogen.sh: gnome-autogen.sh.in Makefile
+## Use sed and then mv to avoid problems if the user interrupts.
+ sed -e 's#\@datadir\@#$(datadir)#g' \
+ < $(srcdir)/gnome-autogen.sh.in > gnome-autogen.tmp \
+ && mv gnome-autogen.tmp gnome-autogen.sh
+
+EXTRA_DIST = gnome-autogen.sh.in