summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>2000-11-21 17:18:11 +0000
committerMartin Baulig <martin@src.gnome.org>2000-11-21 17:18:11 +0000
commit1f8d693b87ce9132f3880809f52ede46727ef5e4 (patch)
treeb9efbc3c57f4d5c98e7beffaa45381ba6ddd64eb /configure.in
parentc0a8b9ac7e2ffa3ec0199412354df7441226bbfc (diff)
downloadshared-mime-info-1f8d693b87ce9132f3880809f52ede46727ef5e4.tar.gz
Set version number to 1.2.1.
2000-11-21 Martin Baulig <martin@home-of-linux.org> * configure.in: Set version number to 1.2.1. * configure.in (--enable-platform-gnome-2): New configure command line argument to enable support for the GNOME 2.x platform. (PLATFORM_GNOME_2): New automake conditional. * Do the GNOME_SUPPORT_CHECKS here if we're on the GNOME 2.x platform. * Makefile.am (SUBDIRS): Conditionally add support for the GNOME 2.x platform. * acinclude.m4: New file. Put stuff from gnome-support.m4 and need-declaration.m4 here. svn path=/trunk/; revision=1466
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 35 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 009adab9..34fd6e22 100644
--- a/configure.in
+++ b/configure.in
@@ -1,12 +1,21 @@
-AC_INIT(intl)
+AC_INIT(support/easy-vsnprintf.c)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(gnome-common, 1.2.0)
+AM_INIT_AUTOMAKE(gnome-common, 1.2.1)
AM_MAINTAINER_MODE
AM_CONDITIONAL(INSIDE_GNOME_COMMON, true)
+AC_ARG_ENABLE(platform-gnome-2, [ --enable-platform-gnome-2 enable GNOME 2.x platform [default=no]],[platform_gnome_2="$enableval"],[platform_gnome_2=no])
+if test "x$platform_gnome_2" != "xyes" ; then
+ platform_gnome_2=no
+fi
+
+AM_CONDITIONAL(PLATFORM_GNOME_2, test $platform_gnome_2 = yes)
+
+AC_DEFUN([AC_FYI], [echo "FYI: " $1])
+
AC_ISC_POSIX
AC_PROG_CC
AC_PROG_CPP
@@ -14,9 +23,32 @@ AC_STDC_HEADERS
AC_ARG_PROGRAM
AM_PROG_LIBTOOL
+AC_PROG_AWK
+
+if test $platform_gnome_2 = yes; then
+ GNOME_INTERFACE_VERSION=2
+ AC_FYI(Enabling GNOME 2 Platform)
+ AC_PATH_PROG(PKG_CONFIG, pkg-config)
+ if ! test -x "$PKG_CONFIG" ; then
+ AC_MSG_ERROR([
+*** You need the latest pkg-config.
+*** Get the latest version of pkg-config from
+*** http://pkgconfig.sourceforce.net.])
+ fi
+ AC_SUBST(PKG_CONFIG)
+ GNOME_SUPPORT_CHECKS
+else
+ GNOME_INTERFACE_VERSION=1
+fi
+AC_SUBST(GNOME_INTERFACE_VERSION)
+
AC_OUTPUT([
+gnome-common.pc
+gnome-common-2.0.pc
Makefile
macros/Makefile
macros2/Makefile
bin/Makefile
-doc/Makefile])
+doc/Makefile
+support/Makefile
+support/gnome-support-2.0.pc])