summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Baulig <martin@src.gnome.org>1999-02-04 13:27:05 +0000
committerMartin Baulig <martin@src.gnome.org>1999-02-04 13:27:05 +0000
commitfede401de24c24de782befee9cb4c88d689e40a5 (patch)
tree91810537b5bdfab4dcafd049a2e58a8030337d70 /configure.in
parent27e19ca975b25e66e49e00bfd80995f2bd017452 (diff)
downloadshared-mime-info-fede401de24c24de782befee9cb4c88d689e40a5.tar.gz
To make this work both for GNOME Applications inside and outside the
GNOME CVS Tree I did the following: * There is an `INSIDE_GNOME_COMMON' automake conditional which is defined in two places: - macros/aclocal-includes.m4 defines this to always be false. - gnome-common/configure.in does not include anything from macros and defines this to be true. * We use this automake conditional in the macros/Makefile.am to install $(MACROS), autogen.sh, gnome-common.m4 and a newly created gnome-macros.dep in `$(datadir)/aclocal/gnome'. Since aclocal doesn't look in subdirectories we can safely install them there even when compiling from CVS. Also, there is no need to make any change to any existing application in the GNOME CVS Tree - really fine ... * When we're outside the GNOME CVS Tree we simply need to tell aclocal that it should also look in `$(datadir)/aclocal/gnome' and it will find all the macros. The is a `gnome-skel' module in CVS that can be used as a starting point when writing a new GNOME Application that should be used outside CVS. February 4, 1999, Martin Baulig <martin@home-of-linux.org> svn path=/trunk/; revision=609
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 4 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index b618884a..db2d990f 100644
--- a/configure.in
+++ b/configure.in
@@ -1,13 +1,11 @@
AC_INIT(intl)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(gnome-common, 0.13)
+AM_INIT_AUTOMAKE(gnome-common, 0.99.5)
AM_MAINTAINER_MODE
-AM_ACLOCAL_INCLUDE(macros)
-
-GNOME_INIT
+AM_CONDITIONAL(INSIDE_GNOME_COMMON, true)
AC_ISC_POSIX
AC_PROG_CC
@@ -16,21 +14,6 @@ AC_STDC_HEADERS
AC_ARG_PROGRAM
AM_PROG_LIBTOOL
-GNOME_SUPPORT_CHECKS
-
-dnl ## internationalization support
-dnl ALL_LINGUAS=""
-dnl AM_GNU_GETTEXT
-dnl AC_LINK_FILES($nls_cv_header_libgt, $nls_cv_header_intl)
-
-AC_OUTPUT(
+AC_OUTPUT([
Makefile
-dnl ## internationalization support
-dnl po/Makefile.in
-dnl intl/Makefile
-macros/Makefile
-support/Makefile
-stamp.h)
-
-dnl ## internationalization support
-dnl stamp.h],[sed -e "/POTFILES =/r po/POTFILES" po/Makefile.in > po/Makefile])
+macros/Makefile])