summaryrefslogtreecommitdiff
path: root/macros/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>1999-02-04 13:04:51 +0000
committerMartin Baulig <martin@src.gnome.org>1999-02-04 13:04:51 +0000
commit27e19ca975b25e66e49e00bfd80995f2bd017452 (patch)
treece51842be22dc64be849b4a80833a9df05b5fedb /macros/Makefile.am
parent1a8f01afe09e7fe6e6096015c3fc0719c6e6dc82 (diff)
downloadshared-mime-info-27e19ca975b25e66e49e00bfd80995f2bd017452.tar.gz
New automake conditional that's always false.
1999-02-04 Martin Baulig <martin@home-of-linux.org> * aclocal-include.m4 (INSIDE_GNOME_COMMON): New automake conditional that's always false. * gnome-common.m4: New file. This defines a `GNOME_COMMON_INIT' macro that should be used in all GNOME Applications outside the CVS tree. * Makefile.am: If we are `INSIDE_GNOME_COMMON', install all $(MACROS), autogen.sh, gnome-common.m4 and a newly created gnome-macros.dep in `$(datadir)/aclocal/gnome'. svn path=/trunk/; revision=605
Diffstat (limited to 'macros/Makefile.am')
-rw-r--r--macros/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/macros/Makefile.am b/macros/Makefile.am
index c3547130..2922a907 100644
--- a/macros/Makefile.am
+++ b/macros/Makefile.am
@@ -22,8 +22,18 @@ MACROS= \
linger.m4 \
need-declaration.m4
-EXTRA_DIST=$(MACROS) autogen.sh
+EXTRA_DIST=$(MACROS) gnome-common.m4 autogen.sh
MAINTAINERCLEANFILES=macros.dep
@MAINT@macros.dep: Makefile.am
@MAINT@ @echo '$$(top_srcdir)/aclocal.m4: $(MACROS:%=macros/%)' > $@
+
+if INSIDE_GNOME_COMMON
+gnome_aclocaldir = $(datadir)/aclocal/gnome
+
+gnome-macros.dep: Makefile.am
+ @echo '$$(top_srcdir)/aclocal.m4: $(MACROS:%=$(gnome_aclocaldir)/%)' > $@
+
+gnome_aclocal_DATA = $(MACROS) gnome-macros.dep gnome-common.m4 autogen.sh
+
+endif