summaryrefslogtreecommitdiff
path: root/support/Makefile.am
diff options
context:
space:
mode:
authorRaja R Harinath <harinath@src.gnome.org>1998-06-11 06:46:13 +0000
committerRaja R Harinath <harinath@src.gnome.org>1998-06-11 06:46:13 +0000
commit30d3f158d5fb2b3081de931f96bbcc8edf76e278 (patch)
tree739ce87749b6f48c6019292d0dae946a90b5b20d /support/Makefile.am
parent74f4cc2206b28a8f0f8d28049ee160430ea57141 (diff)
downloadshared-mime-info-30d3f158d5fb2b3081de931f96bbcc8edf76e278.tar.gz
Build with `gnomesupport.awk'. (CROSS_COMPILING): Remove. New file, to
* Makefile.am (gnomesupport.h): Build with `gnomesupport.awk'. (CROSS_COMPILING): Remove. * gnomesupport.awk: New file, to replace `gnomesupport-h.c'. * gnomesupport-h.c: Removed. Doesn't work well in cross-compiles. svn path=/trunk/; revision=249
Diffstat (limited to 'support/Makefile.am')
-rw-r--r--support/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/support/Makefile.am b/support/Makefile.am
index 394492db..84d51aa5 100644
--- a/support/Makefile.am
+++ b/support/Makefile.am
@@ -5,10 +5,6 @@ supportincludedir = $(pkglibdir)/include
if BUILD_GNOME_SUPPORT
INCLUDES = -D_GNU_SOURCE
-if CROSS_COMPILING
-CC = $(build_CC)
-endif
-
lib_LTLIBRARIES = libgnomesupport.la
supportinclude_HEADERS = gnome-argp.h getopt.h long-options.h argp.h
@@ -25,13 +21,11 @@ libgnomesupport_la_SOURCES = long-options.c gnome-argp.c
libgnomesupport_la_LIBADD = @LTLIBOBJS@
libgnomesupport_la_LDFLAGS = -version-info 0:0:0
-noinst_PROGRAMS = gnomesupport-h
-
BUILT_SOURCES = gnomesupport.h
-gnomesupport.h: gnomesupport-h
- ./gnomesupport-h > gnomesupport.h-new && \
- mv gnomesupport.h-new gnomesupport.h
+gnomesupport.h: gnomesupport.awk $(top_builddir)/config.h
+ $(AWK) -f $(srcdir)/gnomesupport.awk < $(top_builddir)/config.h > gsh-t
+ mv gsh-t gnomesupport.h
endif