summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 718567a5..b143ac35 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -99,3 +99,13 @@ check-translations:
fi; \
done;
+# Build ChangeLog from GIT history
+ChangeLog:
+ @if test -f $(top_srcdir)/.git/HEAD; then \
+ git log --stat --after="Tue Oct 6 14:46:33 2009 +0000" > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+