summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 7 insertions, 27 deletions
diff --git a/configure.in b/configure.in
index 5e78c7e8..528c663b 100644
--- a/configure.in
+++ b/configure.in
@@ -1,19 +1,11 @@
-AC_INIT(support/easy-vsnprintf.c)
+AC_INIT(macros2/gnome-pkgconfig.m4)
-AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(gnome-common, 1.2.1)
+AM_INIT_AUTOMAKE(gnome-common, 1.2.2)
AM_MAINTAINER_MODE
AM_CONDITIONAL(INSIDE_GNOME_COMMON, true)
-AC_ARG_ENABLE(platform-gnome-2, [ --enable-platform-gnome-2 enable GNOME 2.x platform [default=no]],[platform_gnome_2="$enableval"],[platform_gnome_2=no])
-if test "x$platform_gnome_2" != "xyes" ; then
- platform_gnome_2=no
-fi
-
-AM_CONDITIONAL(PLATFORM_GNOME_2, test $platform_gnome_2 = yes)
-
AC_DEFUN([AC_FYI], [echo "FYI: " $1])
AC_ISC_POSIX
@@ -25,32 +17,20 @@ AM_PROG_LIBTOOL
AC_PROG_AWK
-if test $platform_gnome_2 = yes; then
- GNOME_INTERFACE_VERSION=2
- AC_FYI(Enabling GNOME 2 Platform)
- AC_PATH_PROG(PKG_CONFIG, pkg-config)
- if ! test -x "$PKG_CONFIG" ; then
- AC_MSG_ERROR([
+AC_PATH_PROG(PKG_CONFIG, pkg-config)
+if ! test -x "$PKG_CONFIG" ; then
+ AC_MSG_ERROR([
*** You need the latest pkg-config.
*** Get the latest version of pkg-config from
*** http://pkgconfig.sourceforce.net.])
- fi
- AC_SUBST(PKG_CONFIG)
- GNOME_SUPPORT_CHECKS
-else
- GNOME_INTERFACE_VERSION=1
fi
-AC_SUBST(GNOME_INTERFACE_VERSION)
+AC_SUBST(PKG_CONFIG)
AC_OUTPUT([
-gnome-common.pc
-gnome-common-2.0.pc
Makefile
gnome-common.spec
macros/Makefile
macros2/Makefile
bin/Makefile
-doc/Makefile
-support/Makefile
-support/gnome-support-2.0.pc])
+doc/Makefile])