summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build22
1 files changed, 12 insertions, 10 deletions
diff --git a/data/meson.build b/data/meson.build
index 263567d9..24361c97 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -22,14 +22,16 @@ install_data(
install_dir : get_option('datadir') / 'gettext/its'
)
-custom_target('shared-mime-info-spec-html',
- input : 'shared-mime-info-spec.xml',
- output: 'shared-mime-info-spec-html',
- command: [
- xmlto,
- '-o', '@OUTPUT@',
- 'html-nochunks',
- '@INPUT@',
- ],
- build_by_default: true,
+if xmlto.found()
+ custom_target('shared-mime-info-spec-html',
+ input : 'shared-mime-info-spec.xml',
+ output: 'shared-mime-info-spec-html',
+ command: [
+ xmlto,
+ '-o', '@OUTPUT@',
+ 'html-nochunks',
+ '@INPUT@',
+ ],
+ build_by_default: true,
)
+endif