summaryrefslogtreecommitdiff
path: root/support/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'support/Makefile.am')
-rw-r--r--support/Makefile.am24
1 files changed, 9 insertions, 15 deletions
diff --git a/support/Makefile.am b/support/Makefile.am
index 6e0ae3a3..f1a21b19 100644
--- a/support/Makefile.am
+++ b/support/Makefile.am
@@ -2,7 +2,6 @@
supportincludedir = $(pkglibdir)/include
-if BUILD_GNOME_SUPPORT
INCLUDES = -D_GNU_SOURCE
lib_LTLIBRARIES = libgnomesupport.la
@@ -15,10 +14,16 @@ supportinclude_DATA = gnomesupport.h
# These are internal headers: they are used only when compiling and
# should not be installed
-noinst_HEADERS = argp-fmtstream.h argp-namefrob.h gnomesupport-fake.h
+noinst_HEADERS = argp-fmtstream.h argp-namefrob.h gnomesupport-fake.h \
+ findme.h poptint.h
-# gnomesupport.h is listed here to ensure that it is built
-libgnomesupport_la_SOURCES = gnomesupport.h long-options.c gnome-argp.c
+# Hmm... should we move `error.h' here.
+include_HEADERS = popt.h
+
+popt_sources = findme.c poptconfig.c poptparse.c popt.c popthelp.c
+other_sources = long-options.c gnome-argp.c
+
+libgnomesupport_la_SOURCES = gnomesupport.h $(popt_sources) $(other_sources)
libgnomesupport_la_LIBADD = @LTLIBOBJS@
libgnomesupport_la_LDFLAGS = -version-info 0:0:0
@@ -30,14 +35,3 @@ gnomesupport.h: gnomesupport.awk $(top_builddir)/config.h
$(AWK) -f $(srcdir)/gnomesupport.awk < $(top_builddir)/config.h > gsh-t
mv gsh-t gnomesupport.h
-endif
-
-EXTRA_DIST = argp-test.c argp.texi gnomesupport.awk README-gnome \
- argp-ba.c argp-eexst.c argp-fmtstream.c argp-fmtstream.h \
- argp-fs-xinl.c argp-help.c argp-namefrob.h argp-parse.c \
- argp-pv.c argp-pvh.c argp-test.c argp-xinl.c argp.h \
- easy-vsnprintf.c getopt.c getopt.h getopt1.c gnome-argp.c \
- gnome-argp.h long-options.c long-options.h memmove.c mkstemp.c \
- scandir.c strcasecmp.c strerror.c strndup.c strnlen.c strtod.c \
- strtok_r.c strtol.c strtoul.c vasprintf.c vsnprintf.c error.h \
- gnomesupport-fake.h error.c