summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Elstner <danielk@openismus.com>2009-08-06 21:13:44 +0200
committerDaniel Elstner <danielk@openismus.com>2009-08-06 21:36:24 +0200
commitdfbb69c0eb2d6a5b97c8c9d99829fc32c20c4b42 (patch)
tree58eaa41e37b7219019200e0dbdcc2674df557095 /Makefile.am
parent6ce88c9b0a02eefee9ee352d3b8751ab755cb7e1 (diff)
downloadsigc++-dfbb69c0eb2d6a5b97c8c9d99829fc32c20c4b42.tar.gz
Transition to new mm-common build infrastructure
* autogen.sh: Replace with a minimal script that simply executes mm-common-prepare, autoreconf and configure. * configure.ac: Get rid of an enormous amount of old cruft. Use macros from the new mm-common module to set up Doxygen for building the documentation. Add option to enable more compiler warnings. * sigc++-2.0-uninstalled.pc.in: New pkg-config data file to allow linking to an uninstalled libsigc++. * sigc++-2.0.pc.in: Modernize. Provide the location of the installed reference documentation and the Doxygen tag file. * sigc++config.h.in: Modernize and update for new build infrastructure. * Makefile.am, */Makefile.am: Modernize and adapt to the new C++ binding build infrastructure in the mm-common module. * sigc++/filelist.am: New Automake include file. Defines lists of C++ and M4 source files. * docs/Makefile.am: Rewrite using doc-reference.am from the mm-common module. * docs/doc-manual.am: New Automake include file for building the libsigc++ Docbook manual. * docs/images/Makefile.am: Remove file. * docs/manual/Makefile.am: ditto, * docs/reference/Makefile.am: ditto. * docs/Makefile_web.am_fragment: Remove for now, to be taken care of later. * docs/reference/Doxyfile.in: Modernize and adapt to new build infrastructure. * docs/reference/beautify_docs.pl: Remove and use the more recent scripts/doc-postprocess.pl instead. * libsigc++-2.0.spec.in: Remove, to be resurrected only if someone complains. * scripts/Makefile.am: Remove file. Distribute the files from the toplevel Makefile.am instead. * scripts/cxx_std.m4: Add missing third argument to AC_DEFINE(). * scripts/doc-install.pl: New file, copied from mm-common. * scripts/doc-postprocess.pl: ditto, * scripts/tagfile-to-devhelp2.xsl: ditto.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am96
1 files changed, 33 insertions, 63 deletions
diff --git a/Makefile.am b/Makefile.am
index ceabca7..cd17475 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,69 +1,39 @@
-
-# it includes all the autostuff automatically, you just name the
-# other stuff here
-EXTRA_DIST = autogen.sh sigc++config.h.in libsigc++-2.0.spec.in
-# ACLOCAL_FLAGS = -I scripts
-
-SUBDIRS = sigc++ tests docs examples scripts MSVC_Net2005 MSVC_Net2008
-DIST_SUBDIRS = $(SUBDIRS)
+## Copyright (c) 2009 Openismus GmbH <http://www.openismus.com/>
+##
+## This file is part of libsigc++.
+##
+## libsigc++ is free software: you can redistribute it and/or modify it
+## under the terms of the GNU Lesser General Public License as published
+## by the Free Software Foundation, either version 2.1 of the License,
+## or (at your option) any later version.
+##
+## libsigc++ is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+## See the GNU Lesser General Public License for more details.
+##
+## You should have received a copy of the GNU Lesser General Public License
+## along with this library. If not, see <http://www.gnu.org/licenses/>.
+
+ACLOCAL_AMFLAGS = -I scripts ${ACLOCAL_FLAGS}
+
+if ENABLE_DOCUMENTATION
+doc_subdirs = docs
+else
+doc_subdirs =
+endif
+SUBDIRS = sigc++ tests examples $(doc_subdirs) MSVC_Net2005 MSVC_Net2008
sigc_configdir = $(libdir)/sigc++-2.0/include
-sigc_config_DATA = sigc++config.h
+nodist_sigc_config_HEADERS = sigc++config.h
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = sigc++-2.0.pc
-
-all-local:
- @echo "*** Everything completed ***"
-
-dist-hook:
- @echo; echo; \
- echo "**********************************************************"; \
- echo "* IMPORTANT NOTICE: *"; \
- echo "* *"; \
- echo "* Be sure you have done a complete build before running *"; \
- echo "* 'make dist' or 'make distcheck', because otherwise *"; \
- echo "* the tarball will _not_ contain the dependency rules *"; \
- echo "* generated by the compiler. *"; \
- echo "**********************************************************"; \
- echo; echo \
- cp libsigc++-2.0.spec $(distdir)
-
-
-include $(top_srcdir)/docs/Makefile_web.am_fragment
-
-doc_tarball_files = \
- docs/index.html docs/images/*.gif docs/reference/html
-# docs/FAQ/html docs/images/*.gif \
-# docs/internal/*.txt docs/internal/*.dia docs/reference/html \
-# docs/tutorial/figures/*.png docs/tutorial/html
-
-# This doesn't work very well in a $(srcdir) != $(builddir) setup,
-# but this target is for maintainer use only anyway.
-
-libsigc-docs.tar.gz:
- find examples -name '*.cc' -o -name '*.h' -o -name '*.xpm' -o -name '*.xml' | \
- tar cf - --files-from - $(doc_tarball_files) | gzip -c --best >$@
-
-# Upload documentation and examples:
-
-post-html-recursive:
- list='docs examples'; for subdir in $$list; do \
- test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) post-html); \
- done
-
-post-html-local: libsigc-docs.tar.gz
- rsync $(rsync_args) libsigc-docs.tar.gz $$USER@shell.sourceforge.net:$(web_path_libsigc2)
-
-post-html: post-html-recursive post-html-local
-
-doc-clean-recursive:
- (cd docs && $(MAKE) $(AM_MAKEFLAGS) doc-clean)
-
-doc-clean: doc-clean-recursive
-
-doc-rebuild:
- (cd docs && $(MAKE) $(AM_MAKEFLAGS) doc-rebuild)
+nodist_pkgconfig_DATA = sigc++-2.0.pc
+noinst_DATA = sigc++-2.0-uninstalled.pc
-.PHONY: post-html post-html-local post-html-recursive doc-clean doc-clean-recursive doc-rebuild
+dist_noinst_SCRIPTS = autogen.sh
+dist_noinst_DATA = \
+ scripts/doc-install.pl \
+ scripts/doc-postprocess.pl \
+ scripts/tagfile-to-devhelp2.xsl