summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjell.ahlstedt@bredband.net>2013-01-07 10:24:16 +0100
committerKjell Ahlstedt <kjell.ahlstedt@bredband.net>2013-01-07 10:24:16 +0100
commit7c6ff314507bd0beb3b92ebf0a0f6258b67d7796 (patch)
treec60d9df9a13dac8a2bba3bdbdd1df94fca7bf179 /configure.ac
parent12bbd742f1e47422940c3068619cac62a5f5d708 (diff)
downloadsigc++-7c6ff314507bd0beb3b92ebf0a0f6258b67d7796.tar.gz
Documentation: Fix many warnings from Doxygen.
* configure.ac: Require mm-common 0.9.6 or later. * docs/reference/Doxyfile.in: Don't warn for undocumented classes and structs. * sigc++/adaptors/macros/bind.h.m4: * sigc++/adaptors/macros/bind_return.h.m4: * sigc++/adaptors/macros/compose.h.m4: * sigc++/adaptors/macros/hide.h.m4: * sigc++/connection.h: * sigc++/macros/limit_reference.h.m4: Make all parameter names in @param commands equal to the corresponding names in the function declarations. * sigc++/signal_base.h: Remove an extraneous period that confuses Doxygen. * sigc++/type_traits.h: Add a missing @code/@endcode pair.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 864b340..57d9a31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,7 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
AM_MAINTAINER_MODE
AC_ARG_VAR([ACLOCAL_FLAGS], [aclocal flags, e.g. -I <macro dir>])
-MM_PREREQ([0.7.2])
+MM_PREREQ([0.9.6])
MM_INIT_MODULE([sigc++-2.0])
MM_CONFIG_DOCTOOL_DIR([docs])