summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Elstner <danielk@openismus.com>2009-08-07 15:28:41 +0200
committerDaniel Elstner <danielk@openismus.com>2009-08-07 15:28:41 +0200
commitf65fc2607ce3be2ca6a674f52a9e3af14ee31e50 (patch)
tree796165c77807e4912a01ce8b70977a9d53329242 /configure.ac
parent43206ed8c629f2107ecc897aa288aaf70ef9af26 (diff)
downloadsigc++-f65fc2607ce3be2ca6a674f52a9e3af14ee31e50.tar.gz
Do not enable -pedantic mode by default
* configure.ac (MM_ARG_ENABLE_WARNINGS): Remove -pedantic from the list of compiler flags to use at warning level "min" (the default).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bedb0e6..7205533 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,7 +55,7 @@ AS_IF([test "x$config_error" = xyes],
[AC_MSG_FAILURE([[One or more of the required C++ compiler features is missing.]])])
MM_ARG_ENABLE_WARNINGS([SIGC_WXXFLAGS],
- [-pedantic -Wall],
+ [-Wall],
[-pedantic -Wall -Wextra])
AC_CONFIG_FILES([Makefile