summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Elstner <danielk@openismus.com>2009-08-20 08:28:01 +0200
committerDaniel Elstner <danielk@openismus.com>2009-08-20 08:33:51 +0200
commitfcfbfd949199178859a17cfc0458b858e50408bb (patch)
tree54f1feae35f7bafadaa75d523710318f6fd4750e /configure.ac
parent2c53ba63b300eca5a23f2c7cca6a8c9df1e44a2f (diff)
downloadsigc++-fcfbfd949199178859a17cfc0458b858e50408bb.tar.gz
Substitute API version in filenames dynamically
* sigc++.pc.in: Rename file from sigc++-2.0.pc.in. * sigc++-uninstalled.pc.in: Rename file from sigc++-2.0-uninstalled.pc.in. * MSVC_Net200[58]/sigc.rc.in: Rename files from sigc-2.0.rc.in and use @SIGCXX_API_VERSION@ substitution for the API version. Also replace @VERSION@ with @PACKAGE_VERSION@. * MSVC_Net200[58]/libsigc++2.{sln,vcproj}: Remove version from the project name and filenames. * MSVC_Net200[58]/filelist.am: Remove version from filenames. * configure.ac (AC_CONFIG_FILES): Insert ${SIGCXX_MODULE_NAME} into output filenames and remove the version from the input filenames. * Makefile.am: Use $(SIGCXX_MODULE_NAME) in pkg-config file names instead of hard-coding the API version. * sigc++/Makefile.am (lib_LTLIBRARIES): Instead of hard-coding the libtool archive name, substitute @SIGCXX_API_VERSION@ into it, as well as into the derived variable names.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1cb0625..36ea217 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,15 +62,15 @@ MM_ARG_ENABLE_WARNINGS([SIGC_WXXFLAGS],
[-pedantic -Wall -Wextra])
AC_CONFIG_FILES([Makefile
- sigc++-2.0.pc
- sigc++-2.0-uninstalled.pc
+ ${SIGCXX_MODULE_NAME}.pc:sigc++.pc.in
+ ${SIGCXX_MODULE_NAME}-uninstalled.pc:sigc++-uninstalled.pc.in
sigc++/Makefile
examples/Makefile
tests/Makefile
docs/Makefile
docs/reference/Doxyfile
- MSVC_Net2005/sigc-2.0.rc
- MSVC_Net2008/sigc-2.0.rc])
+ MSVC_Net2005/sigc.rc
+ MSVC_Net2008/sigc.rc])
# Copy the generated configuration headers into the MSVC project directories.
AC_CONFIG_COMMANDS([MSVC_Net2005/sigc++config.h],