summaryrefslogtreecommitdiff
path: root/MSVC_NMake/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'MSVC_NMake/meson.build')
-rw-r--r--MSVC_NMake/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/MSVC_NMake/meson.build b/MSVC_NMake/meson.build
index 510daa4..a799535 100644
--- a/MSVC_NMake/meson.build
+++ b/MSVC_NMake/meson.build
@@ -15,3 +15,19 @@ import shutil
shutil.copy2("@0@", "@1@")
'''.format(project_build_root / 'sigc++config.h', project_build_root / 'MSVC_NMake')
meson.add_postconf_script(python3.path(), '-c', cmd_py)
+
+untracked_msvc_nmake = 'untracked' / 'MSVC_NMake'
+handle_built_files = project_source_root / 'tools' / 'handle-built-files.py'
+
+if not meson.is_subproject()
+ # Distribute built files.
+ # (add_dist_script() is not allowed in a subproject)
+
+ meson.add_dist_script(
+ python3.path(), dist_cmd,
+ python3.path(), handle_built_files, 'dist_gen_msvc_files',
+ meson.current_build_dir(),
+ untracked_msvc_nmake,
+ project_build_root / 'sigc++config.h', meson.current_build_dir() / 'sigc.rc',
+ )
+endif