summaryrefslogtreecommitdiff
path: root/docs/docs/reference/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'docs/docs/reference/meson.build')
-rw-r--r--docs/docs/reference/meson.build14
1 files changed, 11 insertions, 3 deletions
diff --git a/docs/docs/reference/meson.build b/docs/docs/reference/meson.build
index fb30c79..8bc659b 100644
--- a/docs/docs/reference/meson.build
+++ b/docs/docs/reference/meson.build
@@ -15,9 +15,17 @@ docinstall_flags = []
foreach module : tag_file_modules
depmod = dependency(module, required: false)
if depmod.found()
- doxytagfile = depmod.get_variable(pkgconfig: 'doxytagfile', internal: 'doxytagfile')
- htmlrefpub = depmod.get_variable(pkgconfig: 'htmlrefpub', internal: 'htmlrefpub', default_value: '')
- htmlrefdir = depmod.get_variable(pkgconfig: 'htmlrefdir', internal: 'htmlrefdir', default_value: '')
+ if meson.version().version_compare('>=0.54.0')
+ doxytagfile = depmod.get_variable(pkgconfig: 'doxytagfile', internal: 'doxytagfile')
+ htmlrefpub = depmod.get_variable(pkgconfig: 'htmlrefpub', internal: 'htmlrefpub', default_value: '')
+ htmlrefdir = depmod.get_variable(pkgconfig: 'htmlrefdir', internal: 'htmlrefdir', default_value: '')
+ else
+ # TODO: Remove the possibility to build with meson.version() < 0.54.0
+ # when >= 0.54.0 is available in GitHub's CI (continuous integration).
+ doxytagfile = depmod.get_variable(pkgconfig: 'doxytagfile')
+ htmlrefpub = depmod.get_variable(pkgconfig: 'htmlrefpub', default_value: '')
+ htmlrefdir = depmod.get_variable(pkgconfig: 'htmlrefdir', default_value: '')
+ endif
if htmlrefpub == ''
htmlrefpub = htmlrefdir
elif htmlrefdir == ''