summaryrefslogtreecommitdiff
path: root/SDL_Core/src/components/Utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'SDL_Core/src/components/Utils/CMakeLists.txt')
-rw-r--r--SDL_Core/src/components/Utils/CMakeLists.txt28
1 files changed, 24 insertions, 4 deletions
diff --git a/SDL_Core/src/components/Utils/CMakeLists.txt b/SDL_Core/src/components/Utils/CMakeLists.txt
index dca9f3d2d..e456a51ff 100644
--- a/SDL_Core/src/components/Utils/CMakeLists.txt
+++ b/SDL_Core/src/components/Utils/CMakeLists.txt
@@ -1,12 +1,32 @@
include_directories (
./include
- ../../thirdPartyLibs/logger/include/
- ../../thirdPartyLibs/logger/log4cplus-1.1.0/include/
- ${CMAKE_BINARY_DIR}/src/thirdPartyLibs/logger/log4cplus-1.1.0/include
+ ../config_profile/include
+ ../media_manager/include/
+ ../protocol_handler/include/
)
set (SOURCES
- ./src/WorkWithOS.cpp
+ ./src/bitstream.cc
+ ./src/conditional_variable_posix.cc
+ ./src/file_system.cc
+ ./src/threads/posix_thread.cc
+ ./src/threads/thread_manager.cc
+ ./src/threads/thread_validator.cc
+ ./src/lock_posix.cc
+ ./src/date_time.cc
+ ./src/signals_linux.cc
)
+if (BUILD_BACKTRACE_SUPPORT)
+ list(APPEND SOURCES
+ ./src/back_trace.cc
+ )
+endif()
+
add_library("Utils" ${SOURCES})
+
+IF(${CMAKE_SYSTEM_NAME} MATCHES "QNX")
+ target_link_libraries ("Utils" log4cxx apr-1 aprutil-1)
+else()
+ target_link_libraries ("Utils" log4cxx apr-1 aprutil-1 rt)
+endif()