summaryrefslogtreecommitdiff
path: root/src/components/media_manager/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/media_manager/test/CMakeLists.txt')
-rw-r--r--src/components/media_manager/test/CMakeLists.txt83
1 files changed, 72 insertions, 11 deletions
diff --git a/src/components/media_manager/test/CMakeLists.txt b/src/components/media_manager/test/CMakeLists.txt
index bb5e076ce..5e5597e88 100644
--- a/src/components/media_manager/test/CMakeLists.txt
+++ b/src/components/media_manager/test/CMakeLists.txt
@@ -1,14 +1,75 @@
-include_directories (
-${CMAKE_SOURCE_DIR}/src/3rd_party-static/gmock-1.7.0/include
-${CMAKE_SOURCE_DIR}/src/3rd_party-static/gmock-1.7.0/gtest/include)
+# Copyright (c) 2014, Ford Motor Company
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# Redistributions of source code must retain the above copyright notice, this
+# list of conditions and the following disclaimer.
+#
+# Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following
+# disclaimer in the documentation and/or other materials provided with the
+# distribution.
+#
+# Neither the name of the Ford Motor Company nor the names of its contributors
+# may be used to endorse or promote products derived from this software
+# without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+# ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+# LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+# CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+# SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
-set(testSources
- main.cc
- media_adapter_impl_test.cc)
+if(BUILD_TESTS)
-set(testLibraries
- gmock
- gtest)
+include_directories(
+ ${GMOCK_INCLUDE_DIRECTORY}
+ ${COMPONENTS_DIR}/media_manager/include
+)
-add_executable(media_manager_test ${testSources})
-target_link_libraries(media_manager_test ${testLibraries})
+if(EXTENDED_MEDIA_MODE)
+ include_directories (
+ ${GSTREAMER_gst_INCLUDE_DIR}
+ ${GLIB_glib_2_INCLUDE_DIR}
+ )
+endif()
+
+set(SOURCES
+ media_manager_impl_test.cc
+ main.cc
+)
+
+set(LIBRARIES
+ MediaManager
+ ApplicationManager
+ ProtocolHandler
+ gmock
+ connectionHandler
+ encryption
+ Resumption
+ Policy
+ ${SecurityManagerLibrary}
+)
+
+if(EXTENDED_MEDIA_MODE)
+ list(APPEND LIBRARIES
+ ${GSTREAMER_gstreamer_LIBRARY})
+endif()
+
+create_test("media_manager_test" "${SOURCES}" "${LIBRARIES}")
+
+if(ENABLE_LOG)
+ target_link_libraries("media_manager_test" log4cxx -L${LOG4CXX_LIBS_DIRECTORY})
+endif()
+
+endif() # BUILD_TESTS
+
+# vim: set ts=2 sw=2 et: