summaryrefslogtreecommitdiff
path: root/test/components/protocol_handler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/components/protocol_handler/CMakeLists.txt')
-rw-r--r--test/components/protocol_handler/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/components/protocol_handler/CMakeLists.txt b/test/components/protocol_handler/CMakeLists.txt
index 804119ce2..5c0dbbdcd 100644
--- a/test/components/protocol_handler/CMakeLists.txt
+++ b/test/components/protocol_handler/CMakeLists.txt
@@ -1,6 +1,7 @@
include_directories(
${GMOCK_INCLUDE_DIRECTORY}
${LOG4CXX_INCLUDE_DIRECTORY}
+ ${CMAKE_SOURCE_DIR}/src/components/utils/include
./include
${CMAKE_SOURCE_DIR}/src/components/protocol_handler/include
${SecurityManagerIncludeDir}
@@ -22,6 +23,8 @@ set(LIBRARIES
set(SOURCES
src/protocol_handler_tm_test.cc
+ src/incoming_data_handler_test.cc
+ src/protocol_header_validator_test.cc
)
create_test(test_ProtocolHandler "${SOURCES}" "${LIBRARIES}")