summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoragaliuzov <agaliuzov@luxoft.com>2015-11-18 21:40:07 +0200
committeragaliuzov <agaliuzov@luxoft.com>2015-11-18 21:40:07 +0200
commit4dac3818b69cbe56dbbcd5899fe2d226f4f45f21 (patch)
treee515b7ee99fbc548025121af19d94c502b8fbdc6 /CMakeLists.txt
parent027650b575c091946bdb8ad8826a43f2d1bf4b89 (diff)
downloadsdl_core-4dac3818b69cbe56dbbcd5899fe2d226f4f45f21.tar.gz
Remove compiler warnings
The compiler generate warnings becaue of using auto_ptr and comparing ifstream with NULL
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5cf7d1186..aef26c2952 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -173,7 +173,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR})
set(ARCHIVE_OUTPUT_DIRECTORY ./bin)
-set(CMAKE_CXX_FLAGS "-fPIC -std=gnu++0x -Wall -Werror -Wuninitialized -Wvla")
+set(CMAKE_CXX_FLAGS "-fPIC -std=gnu++0x -Wall -Werror -Wno-deprecated-declarations -Wuninitialized -Wvla")
if(ENABLE_SANITIZE)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fsanitize=address")