summaryrefslogtreecommitdiff
path: root/src/3rd_party-static/jsoncpp/CMakeLists.txt
diff options
context:
space:
mode:
authorJackLivio <jack@livio.io>2020-02-17 13:05:54 -0500
committerJackLivio <jack@livio.io>2020-02-17 13:05:54 -0500
commit86dea8793023f986c7c10d7f9e5b7a932d89a49a (patch)
treebf44b0d5b6bf6b6c78dd2d0602b67f05ebe2a17c /src/3rd_party-static/jsoncpp/CMakeLists.txt
parent4310b2dfd5e1078df0df53138a73d49d000c9c62 (diff)
parentece258838a44a5461d718c5eeae380ad11a3769b (diff)
downloadsdl_core-fix/3rd_party_build_issues.tar.gz
Merge remote-tracking branch 'origin/develop' into fix/3rd_party_build_issuesfix/3rd_party_build_issues
Diffstat (limited to 'src/3rd_party-static/jsoncpp/CMakeLists.txt')
m---------src/3rd_party-static/jsoncpp0
-rw-r--r--src/3rd_party-static/jsoncpp/CMakeLists.txt42
2 files changed, 0 insertions, 42 deletions
diff --git a/src/3rd_party-static/jsoncpp b/src/3rd_party-static/jsoncpp
new file mode 160000
+Subproject 9e0d70aa66e6ba993dd05723ca64c26ab00f357
diff --git a/src/3rd_party-static/jsoncpp/CMakeLists.txt b/src/3rd_party-static/jsoncpp/CMakeLists.txt
deleted file mode 100644
index ac273cfe7b..0000000000
--- a/src/3rd_party-static/jsoncpp/CMakeLists.txt
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright (c) 2016, Ford Motor Company
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are met:
-#
-# Redistributions of source code must retain the above copyright notice, this
-# list of conditions and the following disclaimer.
-#
-# Redistributions in binary form must reproduce the above copyright notice,
-# this list of conditions and the following
-# disclaimer in the documentation and/or other materials provided with the
-# distribution.
-#
-# Neither the name of the Ford Motor Company nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
-# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-# ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
-# LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
-# CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
-# SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
-# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
-# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
-# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-# POSSIBILITY OF SUCH DAMAGE.
-
-include(${CMAKE_SOURCE_DIR}/tools/cmake/helpers/sources.cmake)
-
-set(JSONCPP_INCLUDE_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/include)
-set(JSONCPP_INCLUDE_DIRECTORY ${JSONCPP_INCLUDE_DIRECTORY} PARENT_SCOPE)
-
-include_directories(
- ${CMAKE_CURRENT_SOURCE_DIR}/include
-)
-
-collect_sources(SOURCES "${CMAKE_CURRENT_SOURCE_DIR}/src/lib_json")
-
-add_library(jsoncpp ${SOURCES})