summaryrefslogtreecommitdiff
path: root/src/appMain/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Kutsan <AKutsan@luxoft.com>2016-01-14 17:13:08 +0200
committerAlexander Kutsan <AKutsan@luxoft.com>2016-01-19 11:40:44 +0200
commit7cd8b4faecb78a2b2f4d05ce481e408ee4827420 (patch)
tree485874e3859ac5eb79b026dc253563429fabb394 /src/appMain/CMakeLists.txt
parent787cba7d339f4ed46395355f3c978f4c5198ea41 (diff)
downloadsdl_core-7cd8b4faecb78a2b2f4d05ce481e408ee4827420.tar.gz
Extract MessageHelper to separate library
For testing parts of ApplicationManager it is nessesary to mock static functions of MessageHelper. But to mock static fuctions of MessageHelper and avoid double definition it is nessesary to extract MessageHelper implementation from ApplicationManager library to separate library and link it if needed.
Diffstat (limited to 'src/appMain/CMakeLists.txt')
-rw-r--r--src/appMain/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/appMain/CMakeLists.txt b/src/appMain/CMakeLists.txt
index 742bd46a96..f82f6563ae 100644
--- a/src/appMain/CMakeLists.txt
+++ b/src/appMain/CMakeLists.txt
@@ -59,6 +59,7 @@ endif()
set(LIBRARIES
MediaManager
ApplicationManager
+ MessageHelperLibrary
HMI_API
MOBILE_API
v4_protocol_v1_2_no_extra