summaryrefslogtreecommitdiff
path: root/src/components/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Kutsan <AKutsan@luxoft.com>2016-11-18 18:12:45 +0200
committerAlexander Kutsan <AKutsan@luxoft.com>2016-12-05 09:33:20 +0200
commit16891012aadef1839f460ddae51d7ee71c2d6ff0 (patch)
treed5b385a0088605c4028b64218d8ecc339e5981a3 /src/components/CMakeLists.txt
parent84f3d3bcd54c1ae1b842e3660c905d9f78cf9d25 (diff)
downloadsdl_core-16891012aadef1839f460ddae51d7ee71c2d6ff0.tar.gz
Fix usages of policy in code
Diffstat (limited to 'src/components/CMakeLists.txt')
-rw-r--r--src/components/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/components/CMakeLists.txt b/src/components/CMakeLists.txt
index d31141b36c..24449143e4 100644
--- a/src/components/CMakeLists.txt
+++ b/src/components/CMakeLists.txt
@@ -58,9 +58,15 @@ add_subdirectory(./utils)
if(ENABLE_SECURITY)
add_subdirectory(./security_manager)
endif()
-#
-# --- Policy_impl
-add_subdirectory(./policy)
+
+
+if (${EXTENDED_POLICY} STREQUAL "EXTENDED_PROPRIETARY")
+ add_subdirectory(./policy/policy_premium/)
+ message(STATUS "Use premium policy")
+else()
+ add_subdirectory(./policy/policy_regular/)
+ message(STATUS "Use promium policy")
+endif()
# --- Validated types
add_subdirectory(./rpc_base)