summaryrefslogtreecommitdiff
path: root/src/components/application_manager/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Kutsan <AKutsan@luxoft.com>2016-05-28 16:01:17 +0300
committerLevchenko <slevchenko@SLevchenko-lws-unq>2016-08-04 17:30:11 +0300
commitf0ab94ebeed8a82e355ca6838e4b427831789288 (patch)
treef13fb7019afd6bae73230ca88935689cf03fec18 /src/components/application_manager/CMakeLists.txt
parent2b41357ed319cdc0606b23ef09643be24bf486bc (diff)
downloadsdl_core-f0ab94ebeed8a82e355ca6838e4b427831789288.tar.gz
AppLaunch Common interfaces
Related issue : APPLINK-24892
Diffstat (limited to 'src/components/application_manager/CMakeLists.txt')
-rw-r--r--src/components/application_manager/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/components/application_manager/CMakeLists.txt b/src/components/application_manager/CMakeLists.txt
index d44cf6c69e..4137a67891 100644
--- a/src/components/application_manager/CMakeLists.txt
+++ b/src/components/application_manager/CMakeLists.txt
@@ -46,6 +46,7 @@ include_directories (
${COMPONENTS_DIR}/config_profile/include/
${COMPONENTS_DIR}/request_watchdog/include/
${COMPONENTS_DIR}/resumption/include/
+ ${COMPONENTS_DIR}/app_launch/include/
${COMPONENTS_DIR}/rpc_base/include/
${COMPONENTS_DIR}/interfaces
${CMAKE_BINARY_DIR}/src/components/
@@ -95,6 +96,12 @@ file (GLOB RESUMPTION
${AM_SOURCE_DIR}/src/resumption/*
)
+
+file (GLOB APP_LAUNCH
+ ${AM_SOURCE_DIR}/src/app_launch/*
+)
+
+
file (GLOB MOBILE_COMMANDS_SOURCES
${AM_SOURCE_DIR}/src/commands/*
${AM_SOURCE_DIR}/src/commands/mobile/*
@@ -382,7 +389,8 @@ add_library("MessageHelper" ${MESSAGE_HELPER_SOURCES})
add_library("AMMobileCommandsLibrary" ${MOBILE_COMMANDS_SOURCES} )
target_link_libraries("AMMobileCommandsLibrary" ${LIBRARIES} AMEventEngine)
-add_library("ApplicationManager" ${SOURCES} ${RESUMPTION})
+add_library("ApplicationManager" ${SOURCES} ${RESUMPTION} ${APP_LAUNCH})
+
target_link_libraries("ApplicationManager" ${LIBRARIES} AMHMICommandsLibrary
AMMobileCommandsLibrary
AMEventEngine