summaryrefslogtreecommitdiff
path: root/src/components/application_manager/test/CMakeLists.txt
diff options
context:
space:
mode:
authorElisey Zamakhov <EZamakhov@luxoft.com>2015-03-18 17:03:42 +0300
committerElisey Zamakhov <EZamakhov@luxoft.com>2015-03-18 17:03:42 +0300
commit4528760d8ab812cd1113cb94cd5b1bcd6e07b841 (patch)
treed353b22bfd173db8abeea29e3e1c4f248b25c2c7 /src/components/application_manager/test/CMakeLists.txt
parent93b9080d910ebcbfae45a36e04aa21309a8e1ba9 (diff)
downloadsdl_core-4528760d8ab812cd1113cb94cd5b1bcd6e07b841.tar.gz
AM tests build fix
Diffstat (limited to 'src/components/application_manager/test/CMakeLists.txt')
-rw-r--r--src/components/application_manager/test/CMakeLists.txt44
1 files changed, 15 insertions, 29 deletions
diff --git a/src/components/application_manager/test/CMakeLists.txt b/src/components/application_manager/test/CMakeLists.txt
index f17f47d342..ee1afbfd19 100644
--- a/src/components/application_manager/test/CMakeLists.txt
+++ b/src/components/application_manager/test/CMakeLists.txt
@@ -43,6 +43,7 @@ set_property(DIRECTORY "" PROPERTY INCLUDE_DIRECTORIES ${the_include_dirs})
include_directories(
${CMAKE_SOURCE_DIR}/src/3rd_party-static/gmock-1.7.0/include
${CMAKE_SOURCE_DIR}/src/3rd_party-static/gmock-1.7.0/gtest/include
+ ${COMPONENTS_DIR}/application_manager/include/application_manager/
${COMPONENTS_DIR}/application_manager/include/application_manager/policies
)
@@ -56,35 +57,10 @@ set(mockedSources
${AM_MOCK_DIR}/src/application_manager_impl.cc
)
-set(AM_SOURCES
- ${AM_SOURCE_DIR}/src/policies/policy_handler.cc
- ${AM_SOURCE_DIR}/src/policies/policy_event_observer.cc
-
- ${AM_SOURCE_DIR}/src/commands/command_impl.cc
- ${AM_SOURCE_DIR}/src/commands/command_request_impl.cc
- ${AM_SOURCE_DIR}/src/commands/command_response_impl.cc
- ${AM_SOURCE_DIR}/src/commands/command_notification_impl.cc
- ${AM_SOURCE_DIR}/src/commands/command_notification_from_mobile_impl.cc
- ${AM_SOURCE_DIR}/src/commands/pending.cc
-
- ${AM_SOURCE_DIR}/src/usage_statistics.cc
- ${AM_SOURCE_DIR}/src/request_info.cc
- ${AM_SOURCE_DIR}/src/message.cc
- ${AM_SOURCE_DIR}/src/application_impl.cc
- ${AM_SOURCE_DIR}/src/mobile_command_factory.cc
- ${AM_SOURCE_DIR}/src/message_helper.cc
- ${AM_SOURCE_DIR}/src/hmi_command_factory.cc
- ${AM_SOURCE_DIR}/src/hmi_capabilities.cc
- ${AM_SOURCE_DIR}/src/application_data_impl.cc
- ${AM_SOURCE_DIR}/src/request_controller.cc
- ${AM_SOURCE_DIR}/src/resume_ctrl.cpp
- ${AM_SOURCE_DIR}/src/mobile_message_handler.cc
+include_directories(
+ ${AM_SOURCE_DIR}/policy/src/policy/policy_table/table_struct
)
- include_directories(
- ${AM_SOURCE_DIR}/policy/src/policy/policy_table/table_struct
- )
-
set(testLibraries
gmock
gmock_main
@@ -120,7 +96,7 @@ if(ENABLE_LOG)
list(APPEND LIBRARIES expat -L${EXPAT_LIBS_DIRECTORY})
endif()
-add_library("ApplicationManagerTest" ${mockedSources} ${testSources} ${AM_SOURCES})
+add_library("ApplicationManagerTest" ${mockedSources} ${testSources})
target_link_libraries("ApplicationManagerTest" ${testLibraries} AMHMICommandsLibrary
AMMobileCommandsLibrary
@@ -128,7 +104,17 @@ target_link_libraries("ApplicationManagerTest" ${testLibraries} AMHMICommandsLib
AMPolicyLibrary)
create_test("application_manager_test" "${testSources}" "${ApplicationManagerTest}")
-target_link_libraries("application_manager_test" ApplicationManagerTest ${test_exec_libraries})
+target_link_libraries("application_manager_test"
+ ApplicationManagerTest ${test_exec_libraries}
+ ApplicationManager
+ ProtocolLibrary
+ connectionHandler
+ ConfigProfile
+ jsoncpp
+ MediaManager
+ ProtocolHandler
+ Resumption
+)
#add_executable(application_manager_test ${testSources})
#target_link_libraries(application_manager_test ApplicationManagerTest ${test_exec_libraries})