summaryrefslogtreecommitdiff
path: root/src/components/application_manager/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Kutsan <akutsan@luxoft.com>2017-01-18 09:43:01 +0200
committerAlex Kutsan <akutsan@luxoft.com>2017-01-18 09:43:01 +0200
commit44263b5e41770bd1f7d156dff71112e02fe68c18 (patch)
tree94df1f4c0264d9b69dc002661290f37d9c5accca /src/components/application_manager/test/CMakeLists.txt
parent0d9c2776edbb0b50bbf878c563cb80df398986ed (diff)
parente325c8bc87099c5743ac54e22ac0c649991b6b45 (diff)
downloadsdl_core-44263b5e41770bd1f7d156dff71112e02fe68c18.tar.gz
Change policies path and fix params method usage
Diffstat (limited to 'src/components/application_manager/test/CMakeLists.txt')
-rw-r--r--src/components/application_manager/test/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/components/application_manager/test/CMakeLists.txt b/src/components/application_manager/test/CMakeLists.txt
index 49de6dbcc9..84354d3f5b 100644
--- a/src/components/application_manager/test/CMakeLists.txt
+++ b/src/components/application_manager/test/CMakeLists.txt
@@ -41,7 +41,9 @@ include_directories(
${COMPONENTS_DIR}/utils/include/
${COMPONENTS_DIR}/resumption/include/
${COMPONENTS_DIR}/utils/include/
- ${COMPONENTS_DIR}/policy/include/
+ ${POLICY_PATH}/include/
+ ${POLICY_PATH}/policy/test/include/
+ ${POLICY_MOCK_INCLUDE_PATH}/
${COMPONENTS_DIR}/media_manager/include/
${COMPONENTS_DIR}/security_manager/include/
${COMPONENTS_DIR}/policy/test/include/
@@ -150,7 +152,7 @@ file(COPY sdl_pt_update.json DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
add_custom_command(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/libPolicy.so
COMMAND ${CMAKE_COMMAND} -E
- copy ${COMPONENTS_DIR}/policy/libPolicy.so ${CMAKE_CURRENT_BINARY_DIR}
+ copy ${POLICY_PATH}/libPolicy.so ${CMAKE_CURRENT_BINARY_DIR}
)
set(CMAKE_EXE_LINKER_FLAGS
"${CMAKE_EXE_LINKER_FLAGS} -Wl,-rpath=${CMAKE_CURRENT_BINARY_DIR}"