summaryrefslogtreecommitdiff
path: root/src/components/connection_handler/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Dickow <jjdickow@gmail.com>2014-10-20 17:44:41 -0400
committerJustin Dickow <jjdickow@gmail.com>2014-10-20 17:44:41 -0400
commit34e7256493ff0e6594029b9857d7e2aa31f5dbeb (patch)
tree367306b507c52d3af211533810adbc22004e0192 /src/components/connection_handler/CMakeLists.txt
parent2eef966e9b5fd4d94dd98820095eb765e200c64b (diff)
downloadsdl_core-34e7256493ff0e6594029b9857d7e2aa31f5dbeb.tar.gz
SDL 3.8!
Signed-off-by: Justin Dickow <jjdickow@gmail.com>
Diffstat (limited to 'src/components/connection_handler/CMakeLists.txt')
-rw-r--r--src/components/connection_handler/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/components/connection_handler/CMakeLists.txt b/src/components/connection_handler/CMakeLists.txt
new file mode 100644
index 0000000000..18946ac349
--- /dev/null
+++ b/src/components/connection_handler/CMakeLists.txt
@@ -0,0 +1,23 @@
+include_directories (
+ ./include/
+ ../protocol_handler/include/
+ ../config_profile/include/
+ ../utils/include/
+ ${ENCRYPTION_INCLUDE_DIRECTORY}
+ ${LOG4CXX_INCLUDE_DIRECTORY}
+)
+
+set (SOURCES
+ ./src/connection_handler_impl.cc
+ ./src/connection.cc
+ ./src/device.cc
+ ./src/heartbeat_monitor.cc
+)
+
+set(LIBRARIES
+ ConfigProfile
+ ProtocolLibrary
+)
+
+add_library(connectionHandler ${SOURCES})
+target_link_libraries(connectionHandler encryption)