summaryrefslogtreecommitdiff
path: root/src/components/connection_handler/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Kutsan <AKutsan@luxoft.com>2016-08-26 18:48:22 +0300
committerAlexander Kutsan <AKutsan@luxoft.com>2016-08-26 18:48:57 +0300
commitd73e6dc8724c5799fae14efd4dcb214af74e4904 (patch)
tree9ebed8b422490c4d669e90e70783e4f5b55b65c9 /src/components/connection_handler/test/CMakeLists.txt
parentc201c11a35d360c0b96f36b103a2590bfaeb6026 (diff)
parent61ef8c42badb879216f53d240e1101b9f83a9bb7 (diff)
downloadsdl_core-d73e6dc8724c5799fae14efd4dcb214af74e4904.tar.gz
Merge branch 'release/4.1.0'
Diffstat (limited to 'src/components/connection_handler/test/CMakeLists.txt')
-rw-r--r--src/components/connection_handler/test/CMakeLists.txt12
1 files changed, 4 insertions, 8 deletions
diff --git a/src/components/connection_handler/test/CMakeLists.txt b/src/components/connection_handler/test/CMakeLists.txt
index 7c0e1b2a98..32da4bdcd8 100644
--- a/src/components/connection_handler/test/CMakeLists.txt
+++ b/src/components/connection_handler/test/CMakeLists.txt
@@ -35,26 +35,22 @@ set(appMain_DIR ${CMAKE_SOURCE_DIR}/src/appMain)
include_directories(
${GMOCK_INCLUDE_DIRECTORY}
${COMPONENTS_DIR}/connection_handler/include
- ${COMPONENTS_DIR}/security_manager/test/include
- ${COMPONENTS_DIR}/protocol_handler/test/include
- ${COMPONENTS_DIR}/security_manager/include
${COMPONENTS_DIR}/connection_handler/test/include
- ${COMPONENTS_DIR}/transport_manager/test/include
+ ${COMPONENTS_DIR}/resumption/include
+ ${JSONCPP_INCLUDE_DIRECTORY}
)
set(LIBRARIES
gmock
connectionHandler
- ConfigProfile
ProtocolHandler
- TransportManager
)
set(SOURCES
- #connection_handler_impl_test.cc
+ connection_handler_impl_test.cc
connection_test.cc
device_test.cc
- #heart_beat_monitor_test.cc
+ heart_beat_monitor_test.cc
)
file(COPY ${appMain_DIR}/smartDeviceLink.ini DESTINATION "./")