summaryrefslogtreecommitdiff
path: root/src/components/dbus/CMakeLists.txt
diff options
context:
space:
mode:
authorjacobkeeler <jacob.keeler@livioradio.com>2018-02-01 13:13:19 -0500
committerjacobkeeler <jacob.keeler@livioradio.com>2018-02-01 13:13:19 -0500
commit3ca6e219ad6325e4ae5486df0f1071c90430a259 (patch)
treebcff58bcc3916e66b57f12c15dab5b2596b0b4ba /src/components/dbus/CMakeLists.txt
parentc1557903ddefeed660a581410442fe50490d1bb0 (diff)
downloadsdl_core-3ca6e219ad6325e4ae5486df0f1071c90430a259.tar.gz
Remove QT HMI API and QT specific RPCsfeature/remove_qt_hmi_api_dbus
Diffstat (limited to 'src/components/dbus/CMakeLists.txt')
-rw-r--r--src/components/dbus/CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/src/components/dbus/CMakeLists.txt b/src/components/dbus/CMakeLists.txt
index 211310d885..6e541126c2 100644
--- a/src/components/dbus/CMakeLists.txt
+++ b/src/components/dbus/CMakeLists.txt
@@ -55,24 +55,6 @@ set(LIBRARIES
dbus-1 -L${DBUS_LIBS_DIRECTORY}
)
-add_custom_command(
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/message_descriptions.cc
- COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/codegen/make_message_descriptions.py
- --infile ${CMAKE_CURRENT_SOURCE_DIR}/../interfaces/QT_HMI_API.xml
- --outdir ${CMAKE_CURRENT_BINARY_DIR}
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../interfaces/QT_HMI_API.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/codegen/make_message_descriptions.py
-)
-
-add_custom_command(
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/introspection_xml.cc
- COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/codegen/make_introspection_c.py
- --infile ${CMAKE_CURRENT_SOURCE_DIR}/../interfaces/QT_HMI_API.xml
- --outdir ${CMAKE_CURRENT_BINARY_DIR}
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../interfaces/QT_HMI_API.xml
- ${CMAKE_CURRENT_SOURCE_DIR}/codegen/make_introspection_c.py
-)
-
add_library("DBus" ${SOURCES})
add_dependecnies("DBus" Utils install-3rd_party_dbus)