summaryrefslogtreecommitdiff
path: root/src/components/dbus/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Dickow <jjdickow@gmail.com>2014-10-20 17:44:41 -0400
committerJustin Dickow <jjdickow@gmail.com>2014-10-20 17:44:41 -0400
commit34e7256493ff0e6594029b9857d7e2aa31f5dbeb (patch)
tree367306b507c52d3af211533810adbc22004e0192 /src/components/dbus/CMakeLists.txt
parent2eef966e9b5fd4d94dd98820095eb765e200c64b (diff)
downloadsdl_core-34e7256493ff0e6594029b9857d7e2aa31f5dbeb.tar.gz
SDL 3.8!
Signed-off-by: Justin Dickow <jjdickow@gmail.com>
Diffstat (limited to 'src/components/dbus/CMakeLists.txt')
-rw-r--r--src/components/dbus/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/src/components/dbus/CMakeLists.txt b/src/components/dbus/CMakeLists.txt
new file mode 100644
index 0000000000..0bea8025e1
--- /dev/null
+++ b/src/components/dbus/CMakeLists.txt
@@ -0,0 +1,45 @@
+include_directories (
+ ${DBUS_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_SOURCE_DIR}/include/
+ ${CMAKE_SOURCE_DIR}/
+ ${CMAKE_SOURCE_DIR}/src/components/
+ ${CMAKE_BINARY_DIR}/src/components/
+ ${CMAKE_SOURCE_DIR}/src/components/formatters/include/
+ ${CMAKE_SOURCE_DIR}/src/components/smart_objects/include/
+ ${CMAKE_SOURCE_DIR}/src/components/utils/include/
+)
+
+set (SOURCES
+ ${CMAKE_CURRENT_BINARY_DIR}/introspection_xml.cc
+ ${CMAKE_CURRENT_BINARY_DIR}/message_descriptions.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/dbus_adapter.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/dbus_message.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/dbus_message_controller.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/schema.cc
+)
+
+set (LIBRARIES dbus-1 -L${DBUS_LIBS_DIRECTORY})
+
+
+add_custom_command(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/message_descriptions.cc
+ COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/codegen/make_message_descriptions.py
+ --infile ${CMAKE_CURRENT_SOURCE_DIR}/../interfaces/QT_HMI_API.xml
+ --outdir ${CMAKE_CURRENT_BINARY_DIR}
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../interfaces/QT_HMI_API.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/codegen/make_message_descriptions.py
+)
+
+add_custom_command(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/introspection_xml.cc
+ COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/codegen/make_introspection_c.py
+ --infile ${CMAKE_CURRENT_SOURCE_DIR}/../interfaces/QT_HMI_API.xml
+ --outdir ${CMAKE_CURRENT_BINARY_DIR}
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../interfaces/QT_HMI_API.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/codegen/make_introspection_c.py
+)
+
+add_library("DBus" ${SOURCES})
+ADD_DEPENDENCIES("DBus" Utils install-3rd_party_dbus)
+
+target_link_libraries("DBus" "${LIBRARIES}")