summaryrefslogtreecommitdiff
path: root/src/components/protocol_handler/CMakeLists.txt
diff options
context:
space:
mode:
authorjacobkeeler <jacob.keeler@livioradio.com>2017-07-25 11:06:20 -0400
committerjacobkeeler <jacob.keeler@livioradio.com>2017-07-25 11:10:49 -0400
commit67966b50aa3a1ab95ea6d6fd591ddfdff5977ef7 (patch)
tree763000b580df123c59e7a88f0f8b03b3900dbe53 /src/components/protocol_handler/CMakeLists.txt
parent2cf2b12f6bd60215eb9ebfcfc15e13beabc864e3 (diff)
downloadsdl_core-67966b50aa3a1ab95ea6d6fd591ddfdff5977ef7.tar.gz
Add BSON library to 3rd party libs
Diffstat (limited to 'src/components/protocol_handler/CMakeLists.txt')
-rw-r--r--src/components/protocol_handler/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/components/protocol_handler/CMakeLists.txt b/src/components/protocol_handler/CMakeLists.txt
index c1dd9b2769..139d52fc53 100644
--- a/src/components/protocol_handler/CMakeLists.txt
+++ b/src/components/protocol_handler/CMakeLists.txt
@@ -35,6 +35,7 @@ include_directories(
${COMPONENTS_DIR}/protocol_handler/include/
${COMPONENTS_DIR}/connection_handler/include/
${LOG4CXX_INCLUDE_DIRECTORY}
+ ${BSON_INCLUDE_DIRECTORY}
)
set(PATHS
@@ -46,6 +47,8 @@ collect_sources(SOURCES "${PATHS}")
set(LIBRARIES
ProtocolLibrary
Utils
+ bson -L${BSON_LIBS_DIRECTORY}
+ emhashmap -L${EMHASHMAP_LIBS_DIRECTORY}
)
get_property(dirs DIRECTORY "" PROPERTY LIBRARIES)
@@ -55,6 +58,7 @@ endforeach()
add_library(ProtocolHandler ${SOURCES})
+add_dependencies(ProtocolHandler install-bson_c_lib)
target_link_libraries(ProtocolHandler ${LIBRARIES})
if(BUILD_TESTS)