summaryrefslogtreecommitdiff
path: root/src/components/rpc_base/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Dickow <jjdickow@gmail.com>2014-10-20 17:44:41 -0400
committerJustin Dickow <jjdickow@gmail.com>2014-10-20 17:44:41 -0400
commit34e7256493ff0e6594029b9857d7e2aa31f5dbeb (patch)
tree367306b507c52d3af211533810adbc22004e0192 /src/components/rpc_base/CMakeLists.txt
parent2eef966e9b5fd4d94dd98820095eb765e200c64b (diff)
downloadsdl_core-34e7256493ff0e6594029b9857d7e2aa31f5dbeb.tar.gz
SDL 3.8!
Signed-off-by: Justin Dickow <jjdickow@gmail.com>
Diffstat (limited to 'src/components/rpc_base/CMakeLists.txt')
-rw-r--r--src/components/rpc_base/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/components/rpc_base/CMakeLists.txt b/src/components/rpc_base/CMakeLists.txt
new file mode 100644
index 0000000000..2a14274145
--- /dev/null
+++ b/src/components/rpc_base/CMakeLists.txt
@@ -0,0 +1,21 @@
+include_directories(
+ include
+ ${JSONCPP_INCLUDE_DIRECTORY}
+)
+
+set (SOURCES
+ src/rpc_base/rpc_base.cc
+)
+
+set (HEADERS
+ include/rpc_base/gtest_support.h
+ include/rpc_base/rpc_base_dbus_inl.h
+ include/rpc_base/rpc_base.h
+ include/rpc_base/rpc_base_inl.h
+ include/rpc_base/rpc_base_json_inl.h
+ include/rpc_base/rpc_message.h
+ include/rpc_base/validation_report.h
+)
+
+add_library(rpc_base ${HEADERS} ${SOURCES})
+target_link_libraries(rpc_base jsoncpp)