summaryrefslogtreecommitdiff
path: root/src/components/security_manager/CMakeLists.txt
diff options
context:
space:
mode:
authorJackLivio <jack@livio.io>2018-08-22 14:33:20 -0400
committerJackLivio <jack@livio.io>2018-08-22 14:33:20 -0400
commit2b9dbd15a3170b89a2ba9752faf56d6a7ee0910c (patch)
treec4b5792cb861816ca9c12d42246f4ce333e39285 /src/components/security_manager/CMakeLists.txt
parent203aedc01958fe8e0825f70599f8cda0f621ae5c (diff)
parent6a436addb2811c3fbc6ff155a8a142aa14c8ec45 (diff)
downloadsdl_core-2b9dbd15a3170b89a2ba9752faf56d6a7ee0910c.tar.gz
Merge remote-tracking branch 'origin/develop' into feature/PLAY_PAUSE_implementation
# Conflicts: # src/appMain/hmi_capabilities.json # src/components/application_manager/src/commands/mobile/subscribe_button_request.cc # src/components/application_manager/test/hmi_capabilities.json # src/components/interfaces/MOBILE_API.xml # src/components/interfaces/QT_HMI_API.xml # src/components/utils/test/test_generator/MOBILE_API.xml
Diffstat (limited to 'src/components/security_manager/CMakeLists.txt')
-rw-r--r--src/components/security_manager/CMakeLists.txt29
1 files changed, 19 insertions, 10 deletions
diff --git a/src/components/security_manager/CMakeLists.txt b/src/components/security_manager/CMakeLists.txt
index 3cc6178931..88bc1ddab4 100644
--- a/src/components/security_manager/CMakeLists.txt
+++ b/src/components/security_manager/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2014, Ford Motor Company
+# Copyright (c) 2015, Ford Motor Company
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -27,29 +27,38 @@
# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
# POSSIBILITY OF SUCH DAMAGE.
-
+
+
+include(${CMAKE_SOURCE_DIR}/tools/cmake/helpers/sources.cmake)
include_directories(
- include/
+ ${COMPONENTS_DIR}/security_manager/include/
${COMPONENTS_DIR}/protocol_handler/include/
${COMPONENTS_DIR}/connection_handler/include
${COMPONENTS_DIR}/config_profile/include/
${COMPONENTS_DIR}/utils/include/
${COMPONENTS_DIR}/application_manager/include/
${JSONCPP_INCLUDE_DIRECTORY}
- ${CMAKE_SOURCE_DIR}/src/thirdPartyLibs/jsoncpp/include
${APR_INCLUDE_DIRECTORY}
)
-set (SOURCES
- ${COMPONENTS_DIR}/security_manager/src/security_manager_impl.cc
- ${COMPONENTS_DIR}/security_manager/src/security_query.cc
- ${COMPONENTS_DIR}/security_manager/src/crypto_manager_impl.cc
- ${COMPONENTS_DIR}/security_manager/src/ssl_context_impl.cc
+set(PATHS
+ ${CMAKE_CURRENT_SOURCE_DIR}/include
+ ${CMAKE_CURRENT_SOURCE_DIR}/src
+)
+collect_sources(SOURCES "${PATHS}")
+
+set(LIBRARIES
+ Utils
+ crypto
+ ssl
+ ProtocolHandler
+ jsoncpp
+ ProtocolLibrary
)
add_library(SecurityManager ${SOURCES})
-target_link_libraries(SecurityManager crypto ssl ProtocolHandler jsoncpp ProtocolLibrary)
+target_link_libraries(SecurityManager ${LIBRARIES})
if(BUILD_TESTS)
add_subdirectory(test)