summaryrefslogtreecommitdiff
path: root/src/components/transport_manager/CMakeLists.txt
diff options
context:
space:
mode:
authorCollin <iCollin@users.noreply.github.com>2021-04-26 15:16:13 -0400
committerGitHub <noreply@github.com>2021-04-26 15:16:13 -0400
commit74ea4bb79b6adf00702e68cf5d502bc3def0f285 (patch)
treec50de8e456277c67ec7fddbe48a3cec41aab2cbf /src/components/transport_manager/CMakeLists.txt
parentb8bb4ae8947c74bde887b1148aa116ac19b8020b (diff)
downloadsdl_core-74ea4bb79b6adf00702e68cf5d502bc3def0f285.tar.gz
Open INI file less (#3688)
* parse all values from one ini file open * wrap ini_read_value to open file for ini_file_test.cc * update profile tests, fix handle leak * refactor ini_parse_line * Apply suggestions from code review Co-authored-by: Jacob Keeler <jacob.keeler@livioradio.com> * parse ini file in to smart object * remove ini_file changes * fix style * small optimization, parse key first * restore open/close config functions * deprecate ini_file * Revert "restore open/close config functions" This reverts commit a03c69403fe14790e6b6738a65820c1ae69e95c5. * move ini parsing to Profile::ParseConfiguration * add DEPREACTED to ini_file * don't print deprecated warnings from test file that is dedicated to deprecated methods * add macros to ini_file.cc * check style Co-authored-by: Jacob Keeler <jacob.keeler@livioradio.com>
Diffstat (limited to 'src/components/transport_manager/CMakeLists.txt')
-rw-r--r--src/components/transport_manager/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/components/transport_manager/CMakeLists.txt b/src/components/transport_manager/CMakeLists.txt
index 82cc00baf2..2086b37b52 100644
--- a/src/components/transport_manager/CMakeLists.txt
+++ b/src/components/transport_manager/CMakeLists.txt
@@ -38,6 +38,7 @@ include_directories (
${COMPONENTS_DIR}/connection_handler/include
${COMPONENTS_DIR}/config_profile/include
${COMPONENTS_DIR}/resumption/include
+ ${COMPONENTS_DIR}/smart_objects/include
${POLICY_GLOBAL_INCLUDE_PATH}/
${JSONCPP_INCLUDE_DIRECTORY}
${LOG4CXX_INCLUDE_DIRECTORY}