summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1776a00bbb..40feb61eb0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -307,7 +307,7 @@ endmacro(GenerateInterface)
# --- Useful macro
macro(create_test NAME SOURCES LIBS)
- add_executable("${NAME}" ${SOURCES})
+ add_executable("${NAME}" ${CMAKE_SOURCE_DIR}/src/components/test_main.cc ${SOURCES})
target_link_libraries("${NAME}" ${LIBS})
target_link_libraries("${NAME}" Utils)
if(CMAKE_SYSTEM_NAME STREQUAL "QNX")