summaryrefslogtreecommitdiff
path: root/src/3rd_party-static/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rd_party-static/CMakeLists.txt')
-rw-r--r--src/3rd_party-static/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/3rd_party-static/CMakeLists.txt b/src/3rd_party-static/CMakeLists.txt
index 029c0b3d8d..1b4591e0aa 100644
--- a/src/3rd_party-static/CMakeLists.txt
+++ b/src/3rd_party-static/CMakeLists.txt
@@ -29,9 +29,18 @@
# POSSIBILITY OF SUCH DAMAGE.
# --- jsoncpp
-add_subdirectory(./jsoncpp)
+include(${CMAKE_SOURCE_DIR}/tools/cmake/helpers/sources.cmake)
+
+set(JSONCPP_INCLUDE_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/jsoncpp/include ${CMAKE_SOURCE_DIR}/src/components/utils/include)
set(JSONCPP_INCLUDE_DIRECTORY ${JSONCPP_INCLUDE_DIRECTORY} PARENT_SCOPE)
+include_directories(
+ ${JSONCPP_INCLUDE_DIRECTORY}
+)
+
+collect_sources(SOURCES "${CMAKE_CURRENT_SOURCE_DIR}/jsoncpp/src/lib_json")
+add_library(jsoncpp ${SOURCES})
+
# --- encryption
add_subdirectory(./encryption)
set(ENCRYPTION_INCLUDE_DIRECTORY ${ENCRYPTION_INCLUDE_DIRECTORY} PARENT_SCOPE)