summaryrefslogtreecommitdiff
path: root/src/3rd_party-static/encryption/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rd_party-static/encryption/CMakeLists.txt')
-rw-r--r--src/3rd_party-static/encryption/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/3rd_party-static/encryption/CMakeLists.txt b/src/3rd_party-static/encryption/CMakeLists.txt
index 2074397cfd..b3860925ba 100644
--- a/src/3rd_party-static/encryption/CMakeLists.txt
+++ b/src/3rd_party-static/encryption/CMakeLists.txt
@@ -45,4 +45,8 @@ set (LIBRARIES crypto -L$ENV{THIRD_PARTY_INSTALL_PREFIX}/${CMAKE_ANDROID_ARCH_AB
add_library("encryption" ${SOURCES})
target_include_directories("encryption" PUBLIC "$ENV{THIRD_PARTY_INSTALL_PREFIX}/${CMAKE_ANDROID_ARCH_ABI}/include")
target_link_libraries("encryption" "${LIBRARIES}")
+
+if(ANDROID)
add_dependencies("encryption" openssl_external)
+endif()
+