summaryrefslogtreecommitdiff
path: root/src/3rd_party-static/libusbx-1.0.16/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rd_party-static/libusbx-1.0.16/CMakeLists.txt')
-rw-r--r--src/3rd_party-static/libusbx-1.0.16/CMakeLists.txt30
1 files changed, 0 insertions, 30 deletions
diff --git a/src/3rd_party-static/libusbx-1.0.16/CMakeLists.txt b/src/3rd_party-static/libusbx-1.0.16/CMakeLists.txt
deleted file mode 100644
index 105406c44e..0000000000
--- a/src/3rd_party-static/libusbx-1.0.16/CMakeLists.txt
+++ /dev/null
@@ -1,30 +0,0 @@
-set(LIBUSB_INCLUDE_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})
-set(LIBUSB_INCLUDE_DIRECTORY ${LIBUSB_INCLUDE_DIRECTORY} PARENT_SCOPE)
-
-set(LIBUSB_LIBS_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
-set(LIBUSB_LIBS_DIRECTORY ${LIBUSB_LIBS_DIRECTORY} PARENT_SCOPE)
-
-include_directories (
- ./libusb/os/
- ./libusb/
- ./
-)
-
-set (LIBUSB_SOURCES
- ./libusb/core.c
- ./libusb/descriptor.c
- ./libusb/hotplug.c
- ./libusb/io.c
- ./libusb/strerror.c
- ./libusb/sync.c
- ./libusb/os/linux_udev.c
- ./libusb/os/linux_netlink.c
- ./libusb/os/linux_usbfs.c
- ./libusb/os/poll_posix.c
- ./libusb/os/threads_posix.c
-)
-
-add_library("Libusb-1.0.16" ${LIBUSB_SOURCES})
-
-
-target_link_libraries("Libusb-1.0.16" udev)