summaryrefslogtreecommitdiff
path: root/src/components/application_manager/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/application_manager/CMakeLists.txt')
-rw-r--r--src/components/application_manager/CMakeLists.txt50
1 files changed, 41 insertions, 9 deletions
diff --git a/src/components/application_manager/CMakeLists.txt b/src/components/application_manager/CMakeLists.txt
index e8db4d46c8..d44cf6c69e 100644
--- a/src/components/application_manager/CMakeLists.txt
+++ b/src/components/application_manager/CMakeLists.txt
@@ -33,9 +33,9 @@ set (AM_SOURCE_DIR ${COMPONENTS_DIR}/application_manager)
set (AM_TEST_DIR ${AM_SOURCE_DIR}/test)
set (AM_MOCK_DIR ${AM_TEST_DIR}/mock)
-
include_directories (
include/
+ ${COMPONENTS_DIR}
${COMPONENTS_DIR}/utils/include/
${COMPONENTS_DIR}/formatters/include/
${COMPONENTS_DIR}/protocol_handler/include/
@@ -49,21 +49,36 @@ include_directories (
${COMPONENTS_DIR}/rpc_base/include/
${COMPONENTS_DIR}/interfaces
${CMAKE_BINARY_DIR}/src/components/
- ${COMPONENTS_DIR}/include/
- ${COMPONENTS_DIR}/policy/src/policy/include/
- ${COMPONENTS_DIR}/policy/src/policy/usage_statistics/include/
+ ${COMPONENTS_DIR}/policy/include/
${JSONCPP_INCLUDE_DIRECTORY}
${ENCRYPTION_INCLUDE_DIRECTORY}
${MESSAGE_BROKER_INCLUDE_DIRECTORY}
${LOG4CXX_INCLUDE_DIRECTORY}
)
+if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+ include_directories(
+ ${COMPONENTS_DIR}/utils/include/utils/sqlite_wrapper/
+ )
+endif ()
+
+if (${CMAKE_SYSTEM_NAME} MATCHES "QNX")
+ include_directories(
+ ${COMPONENTS_DIR}/utils/include/utils/qdb_wrapper/
+ )
+endif()
+
file (GLOB SOURCES
${AM_SOURCE_DIR}/src/*
)
+set (MESSAGE_HELPER_SOURCES
+ ${AM_SOURCE_DIR}/src/message_helper/message_helper.cc
+)
+
set (POLICIES_MANAGER
${AM_SOURCE_DIR}/src/policies/policy_handler.cc
+${AM_SOURCE_DIR}/src/usage_statistics.cc
${AM_SOURCE_DIR}/src/policies/policy_event_observer.cc
${AM_SOURCE_DIR}/src/policies/delegates/app_permission_delegate.cc
${AM_SOURCE_DIR}/src/policies/delegates/statistics_delegate.cc
@@ -72,11 +87,14 @@ ${AM_SOURCE_DIR}/src/policies/delegates/statistics_delegate.cc
include_directories(
${COMPONENTS_DIR}/policy/src/policy/policy_table/table_struct
)
-
file (GLOB EVENT_ENGINE
${AM_SOURCE_DIR}/src/event_engine/*
)
+file (GLOB RESUMPTION
+ ${AM_SOURCE_DIR}/src/resumption/*
+)
+
file (GLOB MOBILE_COMMANDS_SOURCES
${AM_SOURCE_DIR}/src/commands/*
${AM_SOURCE_DIR}/src/commands/mobile/*
@@ -121,8 +139,8 @@ file (GLOB MOBILE_COMMANDS_SOURCES
${AM_SOURCE_DIR}/src/commands/hmi/on_sdl_persistence_complete_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_exit_all_applications_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_exit_application_notification.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/on_navi_way_point_change_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_start_device_discovery.cc
- ${AM_SOURCE_DIR}/src/commands/hmi/on_emergency_event_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/close_popup_request.cc
${AM_SOURCE_DIR}/src/commands/hmi/close_popup_response.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_app_activated_notification.cc
@@ -220,6 +238,10 @@ file (GLOB MOBILE_COMMANDS_SOURCES
${AM_SOURCE_DIR}/src/commands/hmi/navi_show_constant_tbt_response.cc
${AM_SOURCE_DIR}/src/commands/hmi/navi_send_location_request.cc
${AM_SOURCE_DIR}/src/commands/hmi/navi_send_location_response.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/navi_subscribe_way_points_request.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/navi_subscribe_way_points_response.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/navi_unsubscribe_way_points_request.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/navi_unsubscribe_way_points_response.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_ready_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_system_context_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_device_chosen_notification.cc
@@ -232,7 +254,6 @@ file (GLOB MOBILE_COMMANDS_SOURCES
${AM_SOURCE_DIR}/src/commands/hmi/on_ignition_cycle_over_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_system_info_changed_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_file_removed_notification.cc
- ${AM_SOURCE_DIR}/src/commands/hmi/on_play_tone_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_tts_started_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_tts_stopped_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_vr_started_notification.cc
@@ -259,6 +280,8 @@ file (GLOB MOBILE_COMMANDS_SOURCES
${AM_SOURCE_DIR}/src/commands/hmi/navi_audio_start_stream_response.cc
${AM_SOURCE_DIR}/src/commands/hmi/navi_audio_stop_stream_request.cc
${AM_SOURCE_DIR}/src/commands/hmi/navi_audio_stop_stream_response.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/navi_get_way_points_request.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/navi_get_way_points_response.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_system_request_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_put_file_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_resume_audio_source_notification.cc
@@ -278,9 +301,9 @@ file (GLOB MOBILE_COMMANDS_SOURCES
${AM_SOURCE_DIR}/src/commands/hmi/get_urls_response.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_device_state_changed_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_tts_reset_timeout_notification.cc
- ${AM_SOURCE_DIR}/src/commands/hmi/on_phone_call_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/dial_number_request.cc
${AM_SOURCE_DIR}/src/commands/hmi/dial_number_response.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/on_event_changed_notification.cc
)
set (HMI_COMMANDS_SOURCES_JSON
@@ -333,8 +356,13 @@ SET (LIBRARIES
UsageStatistics
dl
formatters
+ dbms
)
+if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ list(APPEND LIBRARIES sqlite3)
+endif ()
+
IF(${CMAKE_SYSTEM_NAME} MATCHES "QNX")
list(REMOVE_ITEM LIBRARIES dl)
endif()
@@ -342,16 +370,19 @@ endif()
add_library("AMEventEngine" ${EVENT_ENGINE})
target_link_libraries("AMEventEngine" ${LIBRARIES})
+
add_library("AMPolicyLibrary" ${POLICIES_MANAGER} )
target_link_libraries("AMPolicyLibrary" ${LIBRARIES} AMEventEngine)
add_library("AMHMICommandsLibrary" ${HMI_COMMANDS_SOURCES})
target_link_libraries("AMHMICommandsLibrary" ${LIBRARIES} AMEventEngine)
+add_library("MessageHelper" ${MESSAGE_HELPER_SOURCES})
+
add_library("AMMobileCommandsLibrary" ${MOBILE_COMMANDS_SOURCES} )
target_link_libraries("AMMobileCommandsLibrary" ${LIBRARIES} AMEventEngine)
-add_library("ApplicationManager" ${SOURCES})
+add_library("ApplicationManager" ${SOURCES} ${RESUMPTION})
target_link_libraries("ApplicationManager" ${LIBRARIES} AMHMICommandsLibrary
AMMobileCommandsLibrary
AMEventEngine
@@ -363,4 +394,5 @@ endif()
if(BUILD_TESTS)
add_subdirectory(test)
+ add_subdirectory(test/message_helper)
endif()