summaryrefslogtreecommitdiff
path: root/src/components/application_manager/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/application_manager/CMakeLists.txt')
-rw-r--r--src/components/application_manager/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/components/application_manager/CMakeLists.txt b/src/components/application_manager/CMakeLists.txt
index 591b2063b9..5448743136 100644
--- a/src/components/application_manager/CMakeLists.txt
+++ b/src/components/application_manager/CMakeLists.txt
@@ -49,13 +49,15 @@ include_directories (
${COMPONENTS_DIR}/request_watchdog/include
${COMPONENTS_DIR}/resumption/include
${COMPONENTS_DIR}/rpc_base/include
- ${COMPONENTS_DIR}/policy/include
+ ${POLICY_PATH}/include/
+ ${POLICY_GLOBAL_INCLUDE_PATH}/
${CMAKE_BINARY_DIR}/src/components
${JSONCPP_INCLUDE_DIRECTORY}
${ENCRYPTION_INCLUDE_DIRECTORY}
${MESSAGE_BROKER_INCLUDE_DIRECTORY}
${LOG4CXX_INCLUDE_DIRECTORY}
)
+MESSAGE (ERROR "${POLICY_PATH}")
if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
include_directories(
@@ -92,7 +94,7 @@ set (POLICIES_MANAGER_SOURCES
)
include_directories(
- ${COMPONENTS_DIR}/policy/src/policy/policy_table/table_struct
+ ${POLICY_PATH}/src/policy/policy_table/table_struct
)
set (EVENT_ENGINE_SOURCE_DIR