summaryrefslogtreecommitdiff
path: root/src/components/application_manager/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/application_manager/test/CMakeLists.txt')
-rwxr-xr-xsrc/components/application_manager/test/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/components/application_manager/test/CMakeLists.txt b/src/components/application_manager/test/CMakeLists.txt
index f6146f96f9..230be524c8 100755
--- a/src/components/application_manager/test/CMakeLists.txt
+++ b/src/components/application_manager/test/CMakeLists.txt
@@ -86,6 +86,9 @@ set (RequestController_SOURCES
${AM_TEST_DIR}/mock_message_helper.cc
)
+set (RPCHandlerImplTest_SOURCES ${AM_TEST_DIR}/rpc_handler_impl_test.cc
+ ${AM_TEST_DIR}/mock_message_helper.cc)
+
set(LIBRARIES
Utils
ApplicationManager
@@ -144,6 +147,8 @@ create_test("help_prompt_manager_test" "${testSourcesHelpPromptManager}" "${LIBR
create_test("request_controller_test" "${RequestController_SOURCES}" "${LIBRARIES}")
+create_test("rpc_handler_impl_test" "${RPCHandlerImplTest_SOURCES}" "${LIBRARIES}")
+
set(ResumptionData_SOURCES
${AM_TEST_DIR}/resumption/resumption_data_test.cc
${AM_TEST_DIR}/resumption/resumption_data_db_test.cc