summaryrefslogtreecommitdiff
path: root/src/components/application_manager/test/commands/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/application_manager/test/commands/CMakeLists.txt')
-rw-r--r--src/components/application_manager/test/commands/CMakeLists.txt30
1 files changed, 17 insertions, 13 deletions
diff --git a/src/components/application_manager/test/commands/CMakeLists.txt b/src/components/application_manager/test/commands/CMakeLists.txt
index 8dafc16471..ab412c7e4e 100644
--- a/src/components/application_manager/test/commands/CMakeLists.txt
+++ b/src/components/application_manager/test/commands/CMakeLists.txt
@@ -35,11 +35,10 @@ include_directories(
${COMPONENTS_DIR}/application_manager/include/
${COMPONENTS_DIR}/application_manager/include/application_manager/
${COMPONENTS_DIR}/application_manager/include/application_manager/commands/
- ${COMPONENTS_DIR}/application_manager/include/application_manager/commands/hmi/
- ${COMPONENTS_DIR}/application_manager/include/application_manager/commands/mobile/
- ${COMPONENTS_DIR}/application_manager/test/include/
- ${COMPONENTS_DIR}/application_manager/test/include/application_manager/
)
+#${COMPONENTS_DIR}/application_manager/test/include/
+#${COMPONENTS_DIR}/application_manager/test/include/application_manager/
+#${COMPONENTS_DIR}/application_manager/src/commands/
set(COMMANDS_TEST_DIR ${AM_TEST_DIR}/commands)
@@ -47,24 +46,29 @@ file(GLOB SOURCES
${COMMANDS_TEST_DIR}/*
${COMPONENTS_DIR}/application_manager/test/mock_message_helper.cc
${COMPONENTS_DIR}/application_manager/test/mock_application_helper.cc
- ${COMPONENTS_DIR}/application_manager/src/smart_object_keys.cc
- ${COMPONENTS_DIR}/application_manager/src/message.cc
- ${COMMANDS_TEST_DIR}/hmi/*
- ${COMMANDS_TEST_DIR}/hmi/hmi_notifications/*
- ${COMMANDS_TEST_DIR}/mobile/*
+ ${COMPONENTS_DIR}/application_manager/test/commands/command_imp_test.cc
+ ${COMPONENTS_DIR}/application_manager/test/commands/command_request_impl_test.cc
+ ${COMPONENTS_DIR}/application_manager/test/commands/command_response_impl_test.cc
)
+#${COMPONENTS_DIR}/application_manager/src/smart_object_keys.cc
+#${COMPONENTS_DIR}/application_manager/src/message.cc
set(LIBRARIES
gmock
Utils
SmartObjects
HMI_API
MOBILE_API
- ApplicationManager
- AMHMICommandsLibrary
- AMMobileCommandsLibrary
connectionHandler
+ ApplicationManager
jsoncpp
+ Policy
)
-create_cotired_test("commands_test" "${SOURCES}" "${LIBRARIES}" )
+create_test("commands_test" "${SOURCES}" "${LIBRARIES}")
+#${COMMANDS_TEST_DIR}/hmi/*
+#${COMMANDS_TEST_DIR}/hmi/hmi_notifications/*
+#${COMMANDS_TEST_DIR}/mobile/*
+#ApplicationManager
+#AMHMICommandsLibrary
+#AMMobileCommandsLibrary