summaryrefslogtreecommitdiff
path: root/src/components/application_manager/test/state_controller/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/application_manager/test/state_controller/CMakeLists.txt')
-rw-r--r--src/components/application_manager/test/state_controller/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/components/application_manager/test/state_controller/CMakeLists.txt b/src/components/application_manager/test/state_controller/CMakeLists.txt
index 243e6218ed..50dd931309 100644
--- a/src/components/application_manager/test/state_controller/CMakeLists.txt
+++ b/src/components/application_manager/test/state_controller/CMakeLists.txt
@@ -30,20 +30,20 @@
if(BUILD_TESTS)
-set(appMain_DIR ${CMAKE_SOURCE_DIR}/src/appMain)
-
include_directories(
${GMOCK_INCLUDE_DIRECTORY}
- ${COMPONENTS_DIR}/application_manager/test/state_controller/include
+ ${COMPONENTS_DIR}/application_manager/test/include
)
set(LIBRARIES
gmock
ApplicationManager
+ connectionHandler
)
set(SOURCES
state_controller_test.cc
+ ${COMPONENTS_DIR}/application_manager/test/mock_message_helper.cc
)
create_test("state_controller_test" "${SOURCES}" "${LIBRARIES}")