summaryrefslogtreecommitdiff
path: root/src/components/application_manager/test/state_controller/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/application_manager/test/state_controller/CMakeLists.txt')
-rw-r--r--src/components/application_manager/test/state_controller/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/components/application_manager/test/state_controller/CMakeLists.txt b/src/components/application_manager/test/state_controller/CMakeLists.txt
index 22f04cb900..d2627c5723 100644
--- a/src/components/application_manager/test/state_controller/CMakeLists.txt
+++ b/src/components/application_manager/test/state_controller/CMakeLists.txt
@@ -46,6 +46,10 @@ set(SOURCES
${COMPONENTS_DIR}/application_manager/test/mock_message_helper.cc
)
+if(${CMAKE_SYSTEM_NAME} MATCHES "Windows")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /bigobj" )
+endif()
+
create_test("state_controller_test" "${SOURCES}" "${LIBRARIES}")
endif()